summaryrefslogtreecommitdiffstats
path: root/package/wpa_supplicant
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-05-30 21:48:54 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-05-30 21:48:54 +0000
commit73493cbc83459b421b0f54be2a7f8726d4bb28f8 (patch)
tree822eb9a7c0d4c3eeb8f22e80a25fdb47d630b889 /package/wpa_supplicant
parentb113caa074a2d66ac113bcce0f5c2a061dca7ed6 (diff)
downloadmaster-31e0f0ae-73493cbc83459b421b0f54be2a7f8726d4bb28f8.tar.gz
master-31e0f0ae-73493cbc83459b421b0f54be2a7f8726d4bb28f8.tar.bz2
master-31e0f0ae-73493cbc83459b421b0f54be2a7f8726d4bb28f8.zip
Major enhancement to hostap.sh script * use common openwrt option naming (e.g. sta instead of manged for mode) * add support for wds vifs * add support for monitor mode * add encryption support * add antenna selection options * add hidden ssid option * other minor fixes Signed-off-by: Vasilis Tsiligiannis <b_tsiligiannis@silverton.gr>
SVN-Revision: 16220
Diffstat (limited to 'package/wpa_supplicant')
-rw-r--r--package/wpa_supplicant/Makefile1
-rw-r--r--package/wpa_supplicant/config2
2 files changed, 2 insertions, 1 deletions
diff --git a/package/wpa_supplicant/Makefile b/package/wpa_supplicant/Makefile
index de1a0a476a..9c541551d9 100644
--- a/package/wpa_supplicant/Makefile
+++ b/package/wpa_supplicant/Makefile
@@ -57,6 +57,7 @@ TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/madwifi $(if $(CONFIG_WPA_SUPPLICA
define Build/Configure
cp $(CONFIG) $(PKG_BUILD_DIR)/wpa_supplicant/.config
$(if $(CONFIG_PACKAGE_kmod-madwifi),,$(SED) 's,^CONFIG_DRIVER_MADWIFI,#CONFIG_DRIVER_MADWIFI,g' $(PKG_BUILD_DIR)/wpa_supplicant/.config)
+ $(if $(CONFIG_PACKAGE_kmod-hostap),,$(SED) 's,^CONFIG_DRIVER_HOSTAP,#CONFIG_DRIVER_HOSTAP,g' $(PKG_BUILD_DIR)/wpa_supplicant/.config)
$(if $(CONFIG_WPA_SUPPLICANT_OPENSSL),$(SED) 's|^CONFIG_TLS.*|CONFIG_TLS=openssl|g' $(PKG_BUILD_DIR)/wpa_supplicant/.config)
endef
diff --git a/package/wpa_supplicant/config b/package/wpa_supplicant/config
index a7283fc484..3ca1cfa655 100644
--- a/package/wpa_supplicant/config
+++ b/package/wpa_supplicant/config
@@ -41,7 +41,7 @@
# Driver interface for Host AP driver
-#CONFIG_DRIVER_HOSTAP=y
+CONFIG_DRIVER_HOSTAP=y
# Driver interface for Agere driver
#CONFIG_DRIVER_HERMES=y