summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-11 05:07:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-11 05:07:58 +0000
commit1312f14a814d78434aee6d08a399964443dc191c (patch)
treec3d640d7612d31149172d4ff2f0317295b1fcddd /package
parent297062fab8b3eb4ebd74c7e2803133b6f7ed82c5 (diff)
downloadmaster-31e0f0ae-1312f14a814d78434aee6d08a399964443dc191c.tar.gz
master-31e0f0ae-1312f14a814d78434aee6d08a399964443dc191c.tar.bz2
master-31e0f0ae-1312f14a814d78434aee6d08a399964443dc191c.zip
add libcgi
SVN-Revision: 6548
Diffstat (limited to 'package')
-rw-r--r--package/libcgi/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/libcgi/Makefile b/package/libcgi/Makefile
new file mode 100644
index 0000000000..5bd7302243
--- /dev/null
+++ b/package/libcgi/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 6372 2007-02-25 23:34:57Z nbd $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libcgi
+PKG_VERSION:=1.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/libcgi
+PKG_MD5SUM:=110af367081d33c7ed6527a1a60fc274
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Build/InstallDev
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ prefix="$(STAGING_DIR)/usr" \
+ install
+endef
+
+$(eval $(call Build/DefaultTargets))