summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-11-11 13:25:31 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-11-11 13:25:31 +0000
commit20ff304ed90da0fa22b3d550fe1045d53eed5a0e (patch)
tree339a703c720af4977791c90da68de7cb07381172 /package
parent348347ce41e6704f1c66a608531d10cb7b78d729 (diff)
downloadmaster-31e0f0ae-20ff304ed90da0fa22b3d550fe1045d53eed5a0e.tar.gz
master-31e0f0ae-20ff304ed90da0fa22b3d550fe1045d53eed5a0e.tar.bz2
master-31e0f0ae-20ff304ed90da0fa22b3d550fe1045d53eed5a0e.zip
base-files: now that the initial password is completely empty (and not primed with "!") adjust login.sh for it to make telnetd available again
SVN-Revision: 28943
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/bin/login.sh4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index da9e6f3727..c515dcf7b1 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=92
+PKG_RELEASE:=93
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/bin/login.sh b/package/base-files/files/bin/login.sh
index a64c84e1e2..b46769a012 100755
--- a/package/base-files/files/bin/login.sh
+++ b/package/base-files/files/bin/login.sh
@@ -1,7 +1,7 @@
#!/bin/sh
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
-if grep -qs '^root:[^!]' /etc/passwd /etc/shadow && [ -z "$FAILSAFE" ]; then
+if grep -qs '^root:[^!:]' /etc/passwd /etc/shadow && [ -z "$FAILSAFE" ]; then
echo "Login failed."
exit 0
else