summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2009-06-04 00:20:01 +0000
committerLars-Peter Clausen <lars@metafoo.de>2009-06-04 00:20:01 +0000
commit246a5b334d62829fa46c3a6bbaf6f0d1e3745fe0 (patch)
treed5293884ca2d345a1568abaecbf8d0d3d9949337 /package
parent782cd2cf27035153ff52e988551408165eb238ce (diff)
downloadmaster-31e0f0ae-246a5b334d62829fa46c3a6bbaf6f0d1e3745fe0.tar.gz
master-31e0f0ae-246a5b334d62829fa46c3a6bbaf6f0d1e3745fe0.tar.bz2
master-31e0f0ae-246a5b334d62829fa46c3a6bbaf6f0d1e3745fe0.zip
More libtool madness: Every package which was using c++ and libtool fixup was linked against libstd++ even though if it should have been linked against uclibc++. This is fixed by providing a special version of libtool fixup for packages which should use uclibc++. Not pretty but functional. Packages linking against uclibc++ should use PKG_FIXUP:=libtool-ucxx instead of PKG_FIXUP:=libtool
Somebody should probably check all packages using c++ with a dependency on stdlibc++ if uclibc++ can be used instead now. SVN-Revision: 16317
Diffstat (limited to 'package')
-rw-r--r--package/libtool/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/libtool/Makefile b/package/libtool/Makefile
index f179cd7c2a..8d50a7adac 100644
--- a/package/libtool/Makefile
+++ b/package/libtool/Makefile
@@ -45,6 +45,8 @@ define Build/InstallDev
mv $(2)/lib/* $(1)/usr/lib/
mv $(2)/include/* $(1)/usr/include/
$(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(2)/bin/libtool
+ $(CP) $(2)/bin/libtool $(2)/bin/libtool-ucxx
+ $(SED) 's,-lstdc++,-luClibc++,g' $(2)/bin/libtool-ucxx
endef
define Package/libltdl/install