summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-19 10:10:20 +0000
committerJohn Crispin <john@openwrt.org>2015-10-19 10:10:20 +0000
commit729a5378cd4e2d0ca9024adc641a74eda5272b61 (patch)
treed8f9eb1afc779bca3dac923c121f63748e66d392 /package
parentc3d310356d74f0f1991583ae08836dd0e23a907f (diff)
downloadmaster-31e0f0ae-729a5378cd4e2d0ca9024adc641a74eda5272b61.tar.gz
master-31e0f0ae-729a5378cd4e2d0ca9024adc641a74eda5272b61.tar.bz2
master-31e0f0ae-729a5378cd4e2d0ca9024adc641a74eda5272b61.zip
kernel: add ath3k module package
Adds a package for the ath3k kernel module, present in 3.18/4.0/4.1 kernels Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com> SVN-Revision: 47223
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index d438fbe7df..9ff291dd0f 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -78,6 +78,25 @@ endef
$(eval $(call KernelPackage,bluetooth))
+define KernelPackage/ath3k
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=ATH3K Kernel Module support
+ DEPENDS:=+kmod-bluetooth +ar3k-firmware
+ KCONFIG:= \
+ CONFIG_BT_ATH3K \
+ CONFIG_BT_HCIUART_ATH3K
+ $(call AddDepends/bluetooth)
+ FILES:= \
+ $(LINUX_DIR)/drivers/bluetooth/ath3k.ko
+ AUTOLOAD:=$(call AutoProbe,ath3k)
+endef
+
+define KernelPackage/ath3k/description
+ Kernel support for ATH3K Module
+endef
+
+$(eval $(call KernelPackage,ath3k))
+
define KernelPackage/bluetooth_6lowpan
SUBMENU:=$(OTHER_MENU)