summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-29 11:56:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-29 11:56:27 +0000
commit91fe3635620bc4de40982c23cbc67307a93bf354 (patch)
treedec75017f39d81a728803b1766451573aa072624 /package
parentfc5426e4bce52e2f0de597899718cf116205c8c0 (diff)
downloadmaster-31e0f0ae-91fe3635620bc4de40982c23cbc67307a93bf354.tar.gz
master-31e0f0ae-91fe3635620bc4de40982c23cbc67307a93bf354.tar.bz2
master-31e0f0ae-91fe3635620bc4de40982c23cbc67307a93bf354.zip
uclibc: to rebuild libc.so.0, mklibs.py needs access to libc_so.a which was not exported by default. use it instead of libc_pic.a
SVN-Revision: 17438
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index e6cbb21617..9e395bf199 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -247,6 +247,7 @@ endef
define Package/libc/install_lib
$(CP) $(filter-out %/libdl_pic.a,$(wildcard $(TOOLCHAIN_DIR)/usr/lib/lib*.a)) $(1)/lib/
+ $(if $(wildcard $(TOOLCHAIN_DIR)/usr/lib/libc_so.a),$(CP) $(TOOLCHAIN_DIR)/usr/lib/libc_so.a $(1)/lib/libc_pic.a)
$(CP) $(TOOLCHAIN_DIR)/usr/lib/gcc/*/*/libgcc.a $(1)/lib/libgcc_s_pic.a
endef