summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-22 23:06:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-22 23:06:40 +0000
commitbd8e5fb7db8431d22fad5eb72a2a38c0f1b50f45 (patch)
tree4f7eeed6b793a65cf049eb6505718ac37eedd014 /package
parent392966798babed140db8ff7266633d65add2edd6 (diff)
downloadmaster-31e0f0ae-bd8e5fb7db8431d22fad5eb72a2a38c0f1b50f45.tar.gz
master-31e0f0ae-bd8e5fb7db8431d22fad5eb72a2a38c0f1b50f45.tar.bz2
master-31e0f0ae-bd8e5fb7db8431d22fad5eb72a2a38c0f1b50f45.zip
move busybox init scripts from base-files into the busybox package and make them depend on busybox menuconfig options
SVN-Revision: 5620
Diffstat (limited to 'package')
-rw-r--r--package/busybox/Makefile9
-rwxr-xr-xpackage/busybox/files/cron (renamed from package/base-files/default/etc/init.d/cron)0
-rwxr-xr-xpackage/busybox/files/httpd (renamed from package/base-files/default/etc/init.d/httpd)0
-rwxr-xr-xpackage/busybox/files/telnet (renamed from package/base-files/default/etc/init.d/telnet)0
4 files changed, 9 insertions, 0 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index cc34737264..0c1efc470a 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -21,6 +21,11 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
+init-y :=
+init-$(CONFIG_BUSYBOX_CONFIG_HTTPD) += httpd
+init-$(CONFIG_BUSYBOX_CONFIG_CROND) += cron
+init-$(CONFIG_BUSYBOX_CONFIG_TELNETD) += telnet
+
define Package/busybox
SECTION:=base
CATEGORY:=Base system
@@ -66,6 +71,10 @@ define Package/busybox/install
IPKG_ARCH="$(ARCH)" \
PREFIX="$(1)" \
install
+ mkdir -p $(1)/etc/init.d
+ for tmp in $(init-y); do \
+ $(INSTALL_BIN) ./files/$$$$tmp $(1)/etc/init.d/$$$$tmp; \
+ done
-rm -rf $(1)/lib64
endef
diff --git a/package/base-files/default/etc/init.d/cron b/package/busybox/files/cron
index e78d02332c..e78d02332c 100755
--- a/package/base-files/default/etc/init.d/cron
+++ b/package/busybox/files/cron
diff --git a/package/base-files/default/etc/init.d/httpd b/package/busybox/files/httpd
index e4f5f48e9c..e4f5f48e9c 100755
--- a/package/base-files/default/etc/init.d/httpd
+++ b/package/busybox/files/httpd
diff --git a/package/base-files/default/etc/init.d/telnet b/package/busybox/files/telnet
index c994c6052f..c994c6052f 100755
--- a/package/base-files/default/etc/init.d/telnet
+++ b/package/busybox/files/telnet