summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-10-20 17:07:08 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-10-20 17:07:08 +0000
commitcfe1bc11adee94c4ce07d50fb960429fa17350aa (patch)
tree3419f13e77f12fd7e4895309acc4e86058e8ec75 /package
parenta525c056d5909a50939374270859d5955bdb16fc (diff)
downloadmaster-31e0f0ae-cfe1bc11adee94c4ce07d50fb960429fa17350aa.tar.gz
master-31e0f0ae-cfe1bc11adee94c4ce07d50fb960429fa17350aa.tar.bz2
master-31e0f0ae-cfe1bc11adee94c4ce07d50fb960429fa17350aa.zip
base-files: only try to execute watchdog if binary is present
SVN-Revision: 18102
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/etc/init.d/watchdog3
2 files changed, 3 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 0fdbf11391..68cebfed73 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=32
+PKG_RELEASE:=33
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/etc/init.d/watchdog b/package/base-files/files/etc/init.d/watchdog
index adb8f57c13..861a1f9eb0 100755
--- a/package/base-files/files/etc/init.d/watchdog
+++ b/package/base-files/files/etc/init.d/watchdog
@@ -3,5 +3,6 @@
START=97
start() {
- [ -c /dev/watchdog ] && watchdog -t 5 /dev/watchdog
+ [ -c /dev/watchdog ] && [ -x /sbin/watchdog ] && \
+ watchdog -t 5 /dev/watchdog
}