summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-25 06:30:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-25 06:30:36 +0000
commitd309c4fa3030ae3a3df5beb28f02ce81a47dd4d0 (patch)
treecfd1ca70545d5578da51cd5ef266eaf6b4124b32 /package
parentd4f72b61ba079f11f4197b23ba35b05bfe9061e1 (diff)
downloadmaster-31e0f0ae-d309c4fa3030ae3a3df5beb28f02ce81a47dd4d0.tar.gz
master-31e0f0ae-d309c4fa3030ae3a3df5beb28f02ce81a47dd4d0.tar.bz2
master-31e0f0ae-d309c4fa3030ae3a3df5beb28f02ce81a47dd4d0.zip
make hotplug2 use the build system cflags
SVN-Revision: 7720
Diffstat (limited to 'package')
-rw-r--r--package/hotplug2/Makefile1
-rw-r--r--package/hotplug2/patches/110-depend_fix.patch13
2 files changed, 14 insertions, 0 deletions
diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
index 6b69bac733..bf7c8c6b09 100644
--- a/package/hotplug2/Makefile
+++ b/package/hotplug2/Makefile
@@ -29,6 +29,7 @@ define Package/hotplug2/description
Hotplug2 is a trivial replacement of some of the UDev functionality
in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
endef
+MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS)"
define Package/hotplug2/install
$(INSTALL_DIR) $(1)/etc
diff --git a/package/hotplug2/patches/110-depend_fix.patch b/package/hotplug2/patches/110-depend_fix.patch
new file mode 100644
index 0000000000..762b26fa18
--- /dev/null
+++ b/package/hotplug2/patches/110-depend_fix.patch
@@ -0,0 +1,13 @@
+Index: hotplug2-0.9/common.mak
+===================================================================
+--- hotplug2-0.9.orig/common.mak 2007-06-25 08:08:59.320226312 +0200
++++ hotplug2-0.9/common.mak 2007-06-25 08:09:03.541584568 +0200
+@@ -10,7 +10,7 @@
+ .PHONY: all clean dep install install-recursive clean-recursive \
+ dep-recursive all-recursive
+
+-MAKEDEP=-gcc $(CFLAGS) -MM $(wildcard *.c *.cc) > .depend
++MAKEDEP=-$(CC) $(CFLAGS) -MM $(wildcard *.c *.cc) > .depend
+ dep: dep-recursive
+ $(MAKEDEP)
+ .depend: