summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-05-26 08:43:52 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-05-26 08:43:52 +0000
commitec662b91415f957ada29045c12eed5758740c695 (patch)
tree9646076b5ea519a5da4fa5e17864ec599bdd1b4a /package
parentf6e6a733f57061a62ff52711e19100a30824b555 (diff)
downloadmaster-31e0f0ae-ec662b91415f957ada29045c12eed5758740c695.tar.gz
master-31e0f0ae-ec662b91415f957ada29045c12eed5758740c695.tar.bz2
master-31e0f0ae-ec662b91415f957ada29045c12eed5758740c695.zip
allow ar7-atm annex a and b co-existence by symlinking firmwares
SVN-Revision: 16071
Diffstat (limited to 'package')
-rw-r--r--package/ar7-atm/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/package/ar7-atm/Makefile b/package/ar7-atm/Makefile
index f8ae39298d..fafc44eedd 100644
--- a/package/ar7-atm/Makefile
+++ b/package/ar7-atm/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -54,12 +54,14 @@ endef
define KernelPackage/sangam-atm-annex-a/install
mkdir -p $(1)/lib/firmware
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/ar0700mp.bin $(1)/lib/firmware/ar0700xx.bin
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/ar0700mp.bin $(1)/lib/firmware/
+ ln -sf ar0700mp.bin $(1)/lib/firmware/ar0700xx.bin
endef
define KernelPackage/sangam-atm-annex-b/install
mkdir -p $(1)/lib/firmware
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/ar0700db.bin $(1)/lib/firmware/ar0700xx.bin
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/ar0700db.bin $(1)/lib/firmware/
+ ln -sf ar0700db.bin $(1)/lib/firmware/ar0700xx.bin
endef
$(eval $(call KernelPackage,sangam-atm-annex-a))