summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-11-03 14:53:24 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-11-03 14:53:24 +0000
commit7beed534039f364b064e2eb87432d3f1fec95e37 (patch)
tree02e70cfb61825df27daf585cdc8008f0c7c9efc3 /target/linux/adm5120/image
parent5d901efb9e21bb3e60f2e43c7512e5ac2b54c755 (diff)
downloadmaster-31e0f0ae-7beed534039f364b064e2eb87432d3f1fec95e37.tar.gz
master-31e0f0ae-7beed534039f364b064e2eb87432d3f1fec95e37.tar.bz2
master-31e0f0ae-7beed534039f364b064e2eb87432d3f1fec95e37.zip
image generation fixes (closes: #2643, #2644) * rewrite mkcsysimg to use an align parameter instead of a fixed size * Edimax images contains the jffs2 end-of-filesystem marker at the right position from now on
SVN-Revision: 9490
Diffstat (limited to 'target/linux/adm5120/image')
-rw-r--r--target/linux/adm5120/image/Makefile14
-rw-r--r--target/linux/adm5120/image/router_le.mk37
2 files changed, 39 insertions, 12 deletions
diff --git a/target/linux/adm5120/image/Makefile b/target/linux/adm5120/image/Makefile
index 710e82be5c..ee8cf42ea8 100644
--- a/target/linux/adm5120/image/Makefile
+++ b/target/linux/adm5120/image/Makefile
@@ -9,7 +9,8 @@ include $(INCLUDE_DIR)/image.mk
LOADER_MAKE := $(NO_TRACE_MAKE) -C lzma-loader KDIR=$(KDIR)
IMGNAME := $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)
-JFFS2EOF := $(KDIR)/jffs2.eof
+JFFS2BLOCK := $(KDIR)/jffs2.block
+JFFS2MARK := $(KDIR)/jffs2.mark
define imgname
$(IMGNAME)-$(2)-$(patsubst jffs2-%,jffs2,$(1))
@@ -21,9 +22,12 @@ endef
define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
- rm -f $(JFFS2EOF)
- touch $(JFFS2EOF)
- $(call prepare_generic_squashfs,$(JFFS2EOF))
+ rm -f $(JFFS2BLOCK)
+ touch $(JFFS2BLOCK)
+ $(call prepare_generic_squashfs,$(JFFS2BLOCK))
+ rm -f $(JFFS2MARK)
+ touch $(JFFS2MARK)
+ $(call add_jffs2_mark,$(JFFS2MARK))
endef
define Image/Build/Loader
@@ -63,7 +67,7 @@ define trxalign/jffs2-64k
endef
define trxalign/squashfs
--a 1024 -f $(KDIR)/root.squashfs -a 0x10000 -A $(JFFS2EOF)
+-a 1024 -f $(KDIR)/root.squashfs -a 0x10000 -A $(JFFS2BLOCK)
endef
define Image/Build/TRX
diff --git a/target/linux/adm5120/image/router_le.mk b/target/linux/adm5120/image/router_le.mk
index 135b8dff53..f08ed564dd 100644
--- a/target/linux/adm5120/image/router_le.mk
+++ b/target/linux/adm5120/image/router_le.mk
@@ -5,6 +5,23 @@
# See /LICENSE for more information.
#
+define trxedimax/jffs2-128k
+-a 0x20000 -f $(KDIR)/root.jffs2-128k
+endef
+
+define trxedimax/jffs2-64k
+-a 0x10000 -f $(KDIR)/root.jffs2-64k
+endef
+
+define trxedimax/squashfs
+-a 1024 -f $(KDIR)/root.squashfs
+endef
+
+define Image/Build/TRXEdimax
+ $(STAGING_DIR_HOST)/bin/trx -o $(1) -f $(KDIR)/vmlinux.lzma \
+ $(call trxedimax/$(2))
+endef
+
define Image/Build/Compex
$(call Image/Build/Loader,$(2),gz,0x80500000,0,y,$(2))
$(call Image/Build/TRX,$(call imgname,$(1),$(2)).trx,$(1),$(KDIR)/loader-$(2).gz)
@@ -12,14 +29,16 @@ endef
define Image/Build/Edimax
$(call Image/Build/Loader,$(2),gz,0x80500000,0x6D8,y,$(2))
- $(call Image/Build/TRXNoloader,$(call imgname,$(1),$(2)).trx,$(1))
- $(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -d -w \
- -r $(KDIR)/loader-$(2).gz::8192 \
- -x $(call imgname,$(1),$(2)).trx \
+ $(call Image/Build/TRXEdimax,$(call imgname,$(1),$(2)).trx,$(1))
+ $(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -v -v -d -w \
+ -r $(KDIR)/loader-$(2).gz::0x1000 \
+ -x $(call imgname,$(1),$(2)).trx:0x10000 \
+ -x $(JFFS2MARK):0x10000 \
$(call imgname,$(1),$(2))-webui.bin
- $(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -d \
- -r $(KDIR)/loader-$(2).gz::8192 \
- -x $(call imgname,$(1),$(2)).trx \
+ $(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -v -v -d \
+ -r $(KDIR)/loader-$(2).gz::0x1000 \
+ -x $(call imgname,$(1),$(2)).trx:0x10000 \
+ -x $(JFFS2MARK):0x10000 \
$(call imgname,$(1),$(2))-xmodem.bin
rm -f $(call imgname,$(1),$(2)).trx
endef
@@ -340,6 +359,10 @@ define Image/Build/Profile/CAS771W
$(call Image/Build/Board/CAS771W/$(1))
endef
+define Image/Build/Profile/BR6104K
+ $(call Image/Build/Board/BR6104K/$(1))
+endef
+
define Image/Build/Profile/BR6104KP
$(call Image/Build/Board/BR6104KP/$(1))
endef