summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.35/003-adm5120_switch.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-06-10 11:21:10 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-06-10 11:21:10 +0000
commit93993b29e0c89d87d13c022753739ebe953c1d19 (patch)
tree791dfbf8b9ce7c95be2ccafa14dce8316c69ce51 /target/linux/adm5120/patches-2.6.35/003-adm5120_switch.patch
parent9bc1e548a19f05e2bafad0461b9ae0b34654cf2a (diff)
downloadmaster-31e0f0ae-93993b29e0c89d87d13c022753739ebe953c1d19.tar.gz
master-31e0f0ae-93993b29e0c89d87d13c022753739ebe953c1d19.tar.bz2
master-31e0f0ae-93993b29e0c89d87d13c022753739ebe953c1d19.zip
adm5120: add kernel 2.6.35 preliminary support
SVN-Revision: 21751
Diffstat (limited to 'target/linux/adm5120/patches-2.6.35/003-adm5120_switch.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.35/003-adm5120_switch.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.35/003-adm5120_switch.patch b/target/linux/adm5120/patches-2.6.35/003-adm5120_switch.patch
new file mode 100644
index 0000000000..fb5fb83127
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.35/003-adm5120_switch.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -614,6 +614,10 @@ config MIPS_AU1X00_ENET
+ If you have an Alchemy Semi AU1X00 based system
+ say Y. Otherwise, say N.
+
++config ADM5120_ENET
++ tristate "ADM5120 Ethernet switch support"
++ depends on ADM5120
++
+ config SGI_IOC3_ETH
+ bool "SGI IOC3 Ethernet"
+ depends on PCI && SGI_IP27
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -213,6 +213,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
+ # This is also a 82596 and should probably be merged
+ obj-$(CONFIG_LP486E) += lp486e.o
+
++obj-$(CONFIG_ADM5120_ENET) += adm5120sw.o
+ obj-$(CONFIG_ETH16I) += eth16i.o
+ obj-$(CONFIG_ZORRO8390) += zorro8390.o 8390.o
+ obj-$(CONFIG_HPLANCE) += hplance.o 7990.o