summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.18/007-adm5120_pci.patch
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-02-28 23:39:14 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-02-28 23:39:14 +0000
commit780d6939b2ae13603734b815b8dd9772842f4c70 (patch)
tree89edc4c1ba07c54a882029bab8d3aa3e96f54683 /target/linux/adm5120/patches-3.18/007-adm5120_pci.patch
parent0e7e585752b3a73d7cb0c368f3a850447e9f79a0 (diff)
downloadmaster-31e0f0ae-780d6939b2ae13603734b815b8dd9772842f4c70.tar.gz
master-31e0f0ae-780d6939b2ae13603734b815b8dd9772842f4c70.tar.bz2
master-31e0f0ae-780d6939b2ae13603734b815b8dd9772842f4c70.zip
adm5120: add 3.18 support
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 44580
Diffstat (limited to 'target/linux/adm5120/patches-3.18/007-adm5120_pci.patch')
-rw-r--r--target/linux/adm5120/patches-3.18/007-adm5120_pci.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.18/007-adm5120_pci.patch b/target/linux/adm5120/patches-3.18/007-adm5120_pci.patch
new file mode 100644
index 0000000000..a5a0abf43b
--- /dev/null
+++ b/target/linux/adm5120/patches-3.18/007-adm5120_pci.patch
@@ -0,0 +1,22 @@
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_PCI_TX4927) += ops-tx4927.o
+ obj-$(CONFIG_BCM47XX) += pci-bcm47xx.o
+ obj-$(CONFIG_BCM63XX) += pci-bcm63xx.o fixup-bcm63xx.o \
+ ops-bcm63xx.o
++obj-$(CONFIG_ADM5120) += pci-adm5120.o
+ obj-$(CONFIG_MIPS_ALCHEMY) += pci-alchemy.o
+ obj-$(CONFIG_SOC_AR71XX) += pci-ar71xx.o
+ obj-$(CONFIG_PCI_AR724X) += pci-ar724x.o
+--- a/include/linux/pci_ids.h
++++ b/include/linux/pci_ids.h
+@@ -1820,6 +1820,9 @@
+
+ #define PCI_VENDOR_ID_CB 0x1307 /* Measurement Computing */
+
++#define PCI_VENDOR_ID_ADMTEK 0x1317
++#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
++
+ #define PCI_VENDOR_ID_SIIG 0x131f
+ #define PCI_SUBVENDOR_ID_SIIG 0x131f
+ #define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000