summaryrefslogtreecommitdiffstats
path: root/target/linux/amazon-2.6/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-07-23 22:10:11 +0000
committerJohn Crispin <john@openwrt.org>2007-07-23 22:10:11 +0000
commit7470547083506f15a893165e8e312a9bf4eac893 (patch)
treed996fa1661834d1fd45591bae6b977ad894c4530 /target/linux/amazon-2.6/Makefile
parentbee289741948605001e405bb1fdb92b60b36b17c (diff)
downloadmaster-31e0f0ae-7470547083506f15a893165e8e312a9bf4eac893.tar.gz
master-31e0f0ae-7470547083506f15a893165e8e312a9bf4eac893.tar.bz2
master-31e0f0ae-7470547083506f15a893165e8e312a9bf4eac893.zip
initial merge of infineon code for amazon, pci is still broken a bit. a big thank you goes to infineon for providing info and reference code
SVN-Revision: 8137
Diffstat (limited to 'target/linux/amazon-2.6/Makefile')
-rw-r--r--target/linux/amazon-2.6/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/amazon-2.6/Makefile b/target/linux/amazon-2.6/Makefile
new file mode 100644
index 0000000000..1967d52f42
--- /dev/null
+++ b/target/linux/amazon-2.6/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=amazon
+BOARDNAME:=Infineon Amazon
+FEATURES:=squashfs jffs2 broken
+
+define Target/Description
+ Build firmware images for Infineon Amazon boards
+endef
+
+KERNELNAME:="uImage"
+
+include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildKernel))