summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-07-21 17:08:14 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-07-21 17:08:14 +0000
commitf529a3742043a23da4f715c3664d5a822b1f970c (patch)
treea4cdaee84e23765d98072df25883f365cbc0d66a /target/linux/ar71xx/Makefile
parent3d9c4c9073deaf01d592d6940af21be81d92e88a (diff)
downloadmaster-31e0f0ae-f529a3742043a23da4f715c3664d5a822b1f970c.tar.gz
master-31e0f0ae-f529a3742043a23da4f715c3664d5a822b1f970c.tar.bz2
master-31e0f0ae-f529a3742043a23da4f715c3664d5a822b1f970c.zip
surprise :p
SVN-Revision: 11894
Diffstat (limited to 'target/linux/ar71xx/Makefile')
-rw-r--r--target/linux/ar71xx/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
new file mode 100644
index 0000000000..849f4c2155
--- /dev/null
+++ b/target/linux/ar71xx/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=ar71xx
+BOARDNAME:=Atheros AR71xx
+FEATURES:=squashfs tgz broken
+
+LINUX_VERSION:=2.6.25.10
+
+include $(INCLUDE_DIR)/target.mk
+
+#DEFAULT_PACKAGES += kmod-madwifi
+
+define Target/Description
+ Build firmware images for Atheros AR71xx based boards
+endef
+
+$(eval $(call BuildTarget))