summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/base-files/lib/ar71xx.sh
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-11-30 18:31:03 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-11-30 18:31:03 +0000
commit1fa75d430a5c042e50478c02dfdd6d107a99c040 (patch)
tree6993644dd0031e149080f8adfdbc92740ba11c1e /target/linux/ar71xx/base-files/lib/ar71xx.sh
parent367406246927bc3521fcdf957082f6886eae03a6 (diff)
downloadmaster-31e0f0ae-1fa75d430a5c042e50478c02dfdd6d107a99c040.tar.gz
master-31e0f0ae-1fa75d430a5c042e50478c02dfdd6d107a99c040.tar.bz2
master-31e0f0ae-1fa75d430a5c042e50478c02dfdd6d107a99c040.zip
ar71xx: sysupgrade for My Net Wi-Fi Range Extender
This patch enables the convenient sysupgrade feature for WD's Wi-Fi Range Extender. Signed-off-by: Christian Lamparter <chunkeey@googlemail.com> Patchwork: http://patchwork.openwrt.org/patch/4341/ [juhosg: - rename 'mynet_rext_check_image' function to 'cybertan_check_image' and move that into platform.sh, - remove the the model specific 'platform_do_upgrade_mynet_rext' function, - drop the mynet-rext.sh script, - remove the image/Makefile change, - update commit message] [christian: - check all 8 bytes of the firmware/device magic] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38966
Diffstat (limited to 'target/linux/ar71xx/base-files/lib/ar71xx.sh')
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index e0b8830161..0b18d0ce10 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -53,6 +53,15 @@ wndr3700_board_detect() {
AR71XX_MODEL="$machine"
}
+cybertan_get_hw_magic() {
+ local part
+
+ part=$(find_mtd_part firmware)
+ [ -z "$part" ] && return 1
+
+ dd bs=8 count=1 skip=0 if=$part 2>/dev/null | hexdump -v -n 8 -e '1/1 "%02x"'
+}
+
tplink_get_hwid() {
local part