summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/base-files/lib/ar71xx.sh
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-19 17:55:25 +0000
committerJohn Crispin <john@openwrt.org>2015-10-19 17:55:25 +0000
commit8d8a937272fd03902d4e40888efcf3ff707c0d57 (patch)
treec4f6626928a3dad1d94cc2e9f4ab9ef77429d453 /target/linux/ar71xx/base-files/lib/ar71xx.sh
parent795cc23a08b7e70743a125bc4f9c2fa7d284a26c (diff)
downloadmaster-31e0f0ae-8d8a937272fd03902d4e40888efcf3ff707c0d57.tar.gz
master-31e0f0ae-8d8a937272fd03902d4e40888efcf3ff707c0d57.tar.bz2
master-31e0f0ae-8d8a937272fd03902d4e40888efcf3ff707c0d57.zip
ar71xx: Add Gainstrong MiniBox v1.0 support to trunk
This patch supersedes the v1 from September 17th. Bumping the patch version - the MiniBox profile showed up under M, but since it's called 'Gainstrong MiniBox v1.0' now it looks out of place. Renamed the profile to gs-minibox-v1.mk to fix that. The following patch adds support for the Gainstrong MiniBox into trunk (or 'Designated Driver' :D ). Fixed items: - Inverted LED polarity (OOLITE seems to suffer from the same problem). - Changed uppercase MINIBOX_V1_ prefix as requested. - Prefixes are now gs_minibox_ similar to gs_oolite_ (same vendor). - Mention the vendor (Gainstrong) in code headers. Compiles fine, has been confirmed working by owners on 15.05. Question: I've seen some boards use tools/firmware-utils/src/mktplinkfw.c, the MiniBox images build fine without, so I'm wondering: do I need to add it in there as well? Any added benefit? Thank you Signed-off by: Stijn Segers <francesco.borromini@inventati.org> SVN-Revision: 47234
Diffstat (limited to 'target/linux/ar71xx/base-files/lib/ar71xx.sh')
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 166e52ea45..5f02e4e1ca 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -119,6 +119,9 @@ tplink_board_detect() {
"3C0001"*)
model="OOLITE"
;;
+ "3C0002"*)
+ model="MINIBOX_V1"
+ ;;
"070300"*)
model="TP-Link TL-WR703N"
;;
@@ -520,6 +523,9 @@ ar71xx_board_detect() {
*"MAC1200R")
name="mc-mac1200r"
;;
+ *"MiniBox V1.0")
+ name="minibox-v1"
+ ;;
*MR12)
name="mr12"
;;