summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/compex.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-06-23 19:33:07 +0200
committerJohn Crispin <john@phrozen.org>2016-06-23 19:33:31 +0200
commit387477350334daf8cd6adf72f63eddae83785614 (patch)
treeffa65aadbb9341ec560af9cd21879e8822e46ac2 /target/linux/ar71xx/generic/profiles/compex.mk
parentcb7aa4b1fee688342950d02195b927962295514e (diff)
downloadmaster-31e0f0ae-387477350334daf8cd6adf72f63eddae83785614.tar.gz
master-31e0f0ae-387477350334daf8cd6adf72f63eddae83785614.tar.bz2
master-31e0f0ae-387477350334daf8cd6adf72f63eddae83785614.zip
Revert "ar71xx: fix legacy image building"
This reverts commit 59e98b27c93d282edb62fad756fd1c1e587c067f. and Revert "ar71xx: merge profiles into image building code" This reverts commit 636089ead6864364798ac988299429d171051c0e. these are still causing issues Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/compex.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/compex.mk68
1 files changed, 68 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/compex.mk b/target/linux/ar71xx/generic/profiles/compex.mk
new file mode 100644
index 0000000000..54d8503c70
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/compex.mk
@@ -0,0 +1,68 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WP543
+ NAME:=Compex WP543/WPJ543
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/WP543/Description
+ Package set optimized for the Compex WP543/WPJ543 boards.
+endef
+
+$(eval $(call Profile,WP543))
+
+define Profile/WPE72
+ NAME:=Compex WPE72/WPE72NX
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/WPE72/Description
+ Package set optimized for the Compex WPE72 boards including Compex WPE72NX Indoor Access Point.
+endef
+
+$(eval $(call Profile,WPE72))
+
+define Profile/WPJ342
+ NAME:=Compex WPJ342
+endef
+
+define Profile/WPJ342/Description
+ Package set optimized for the Compex WPJ342 board.
+endef
+
+$(eval $(call Profile,WPJ342))
+
+define Profile/WPJ344
+ NAME:=Compex WPJ344
+endef
+
+define Profile/WPJ344/Description
+ Package set optimized for the Compex WPJ344 board.
+endef
+
+$(eval $(call Profile,WPJ344))
+
+define Profile/WPJ531
+ NAME:=Compex WPJ531
+endef
+
+define Profile/WPJ531/Description
+ Package set optimized for the Compex WPJ531 board.
+endef
+
+$(eval $(call Profile,WPJ531))
+
+define Profile/WPJ558
+ NAME:=Compex WPJ558
+endef
+
+define Profile/WPJ558/Description
+ Package set optimized for the Compex WPJ558 board.
+endef
+
+$(eval $(call Profile,WPJ558))