summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/meraki.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-05-23 15:27:22 +0000
committerJohn Crispin <john@openwrt.org>2015-05-23 15:27:22 +0000
commit66950455b7d1c462db1a1fd72622f0703d55ce6e (patch)
tree58db7358376b84d8a31a1edc74c9af95ea983fbe /target/linux/ar71xx/generic/profiles/meraki.mk
parent870cd41936c351c621f4e032ff80489125a90e9f (diff)
downloadmaster-31e0f0ae-66950455b7d1c462db1a1fd72622f0703d55ce6e.tar.gz
master-31e0f0ae-66950455b7d1c462db1a1fd72622f0703d55ce6e.tar.bz2
master-31e0f0ae-66950455b7d1c462db1a1fd72622f0703d55ce6e.zip
ar71xx: Add support for the Meraki MR12 & MR16
This patch is to add support for the Meraki MR12 and MR16 Access Points. Currently everything is working, minus the 2nd NIC interface on the MR12 which is built into the SoC. Signed-off-by: Chris R Blake <chrisrblake93 at gmail.com> SVN-Revision: 45726
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/meraki.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/meraki.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/meraki.mk b/target/linux/ar71xx/generic/profiles/meraki.mk
new file mode 100644
index 0000000000..0d5cda0fd2
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/meraki.mk
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2014-2015 Chris Blake (chrisrblake93@gmail.com)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MR12
+ NAME:=Meraki MR12
+ PACKAGES:=kmod-spi-gpio kmod-ath9k
+endef
+
+define Profile/MR12/description
+ Package set optimized for the Cisco Meraki MR12 Access Point.
+endef
+
+define Profile/MR16
+ NAME:=Meraki MR16
+ PACKAGES:=kmod-spi-gpio kmod-ath9k
+endef
+
+define Profile/MR16/description
+ Package set optimized for the Cisco Meraki MR16 Access Point.
+endef
+
+$(eval $(call Profile,MR12))
+$(eval $(call Profile,MR16)) \ No newline at end of file