summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-09-15 10:19:38 +0000
committerJohn Crispin <john@openwrt.org>2014-09-15 10:19:38 +0000
commit7dbbdfb61f99a765ff02d40daa1d63c769df41ef (patch)
tree2d02c4580ff00b8f32bcb252edae867b296133d7 /target/linux/ar71xx/generic/profiles
parentb520e9b8d441b85e17e29b854306179f1bdb4787 (diff)
downloadmaster-31e0f0ae-7dbbdfb61f99a765ff02d40daa1d63c769df41ef.tar.gz
master-31e0f0ae-7dbbdfb61f99a765ff02d40daa1d63c769df41ef.tar.bz2
master-31e0f0ae-7dbbdfb61f99a765ff02d40daa1d63c769df41ef.zip
ar71xx: add qihoo 360 c301 router support
Qihoo 360 C301 is a dual band wireless router supports 802.11n and 802.11ac. Its chipset is AR9344 + AR9882 with two 16MB flashes. This patch adds its initial support. v2: * use mtd_get_mac_ascii to fetch MAC address for ath10k. * use ath79_register_pci to initialize AR9882. Signed-off-by: Weijie Gao <hackpascal@gmail.com> SVN-Revision: 42552
Diffstat (limited to 'target/linux/ar71xx/generic/profiles')
-rw-r--r--target/linux/ar71xx/generic/profiles/qihoo.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/qihoo.mk b/target/linux/ar71xx/generic/profiles/qihoo.mk
new file mode 100644
index 0000000000..0ec778ab2b
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/qihoo.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/QIHOO360
+ NAME:=Qihoo 360 C301
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev kmod-ath10k
+endef
+
+define Profile/QIHOO360/Description
+ Package set optimized for the Qihoo 360 C301 device.
+endef
+$(eval $(call Profile,QIHOO360))