summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-08-17 06:16:54 +0000
committerJohn Crispin <john@openwrt.org>2015-08-17 06:16:54 +0000
commit4463bc017beba6be6c484f0ff5e9d381debafe38 (patch)
treef81909ba8f3ca67b7e791e950431ff609ccb1dc5 /target/linux/ar71xx/generic
parent9b0516c9fc993745cab983e9ada3e4b00185855c (diff)
downloadmaster-31e0f0ae-4463bc017beba6be6c484f0ff5e9d381debafe38.tar.gz
master-31e0f0ae-4463bc017beba6be6c484f0ff5e9d381debafe38.tar.bz2
master-31e0f0ae-4463bc017beba6be6c484f0ff5e9d381debafe38.zip
ar71xx: Add support for Black Swift
Add support for the Black Swift board: http://www.black-swift.com/ Took relevant parts and slightly adapted from: https://github.com/blackswift/openwrt/blob/master/bsb.patch Signed-off-by: Bruno Randolf <br1@einfach.org> SVN-Revision: 46651
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/smartelectronics.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/smartelectronics.mk b/target/linux/ar71xx/generic/profiles/smartelectronics.mk
new file mode 100644
index 0000000000..6d3dc8c345
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/smartelectronics.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BSB
+ NAME:=Smart Electronics Black Swift board
+ PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/BSB/Description
+ Package set optimized for the Smart Electronics Black Swift board.
+endef
+
+$(eval $(call Profile,BSB))