summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-25 20:37:35 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-25 20:37:35 +0000
commitf7879cd8d889aa13768c014a582fc593aa0313ad (patch)
treeffc75934b62f762fe287c56e7e2bbabc67521844 /target/linux/ar71xx/generic
parentea71239d8a194279e6e895d8da1cc155021ae6f1 (diff)
downloadmaster-31e0f0ae-f7879cd8d889aa13768c014a582fc593aa0313ad.tar.gz
master-31e0f0ae-f7879cd8d889aa13768c014a582fc593aa0313ad.tar.bz2
master-31e0f0ae-f7879cd8d889aa13768c014a582fc593aa0313ad.zip
ar71xx: add profile and build image fot the TL-WA830RE v1 board
Added support for the TP-LINK TL-WA830RE v1 Range Extender. Based on the WA901ND v1 support. Hardware IDs checked against original firmware. Patch was successfully tested on hardware. Signed-off-by: Ronald Hecht <ronald.hecht@gmx.de> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35789
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index f554e22fd0..be88ac78e1 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -102,6 +102,16 @@ define Profile/TLWA801/Description
endef
$(eval $(call Profile,TLWA801))
+define Profile/TLWA830
+ NAME:=TP-LINK TL-WA830RE
+ PACKAGES:=
+endef
+
+define Profile/TLWA830/Description
+ Package set optimized for the TP-LINK TL-WA830RE.
+endef
+$(eval $(call Profile,TLWA830))
+
define Profile/TLWA901
NAME:=TP-LINK TL-WA901N/ND