summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-02-28 17:47:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-02-28 17:47:33 +0000
commit1b4c9db08f5170d1f4e858250faf4e397dda712d (patch)
treec047a5b6e9403125087fc097d65b29430772b63e /target/linux/ar71xx/image/Makefile
parent4b9c8e7ce59c329a90e129f3400bf6e862086d71 (diff)
downloadmaster-31e0f0ae-1b4c9db08f5170d1f4e858250faf4e397dda712d.tar.gz
master-31e0f0ae-1b4c9db08f5170d1f4e858250faf4e397dda712d.tar.bz2
master-31e0f0ae-1b4c9db08f5170d1f4e858250faf4e397dda712d.zip
add initial profiles
SVN-Revision: 14693
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index c96456759c..720be1c1e0 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -179,6 +179,16 @@ define Image/Build/Profile/TLWR941NDV2
$(call Image/Build/Template/TPLINK/$(1),tl-wr941ndv2,board=TL-WR941ND,TL-WR941NDv2)
endef
+define Image/Build/Profile/Default
+ $(call Image/Build/Profile/DIR615C1,$(1))
+ $(call Image/Build/Profile/MZKW04NU,$(1))
+ $(call Image/Build/Profile/TEW632BRP,$(1))
+ $(call Image/Build/Profile/TEW652BRP,$(1))
+ $(call Image/Build/Profile/TLWR941NDV2,$(1))
+ $(call Image/Build/Profile/UBNTRS,$(1))
+ $(call Image/Build/Profile/WP543,$(1))
+endef
+
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
endef
@@ -187,13 +197,7 @@ define Image/Build
$(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(IMGNAME)-root.$(1) bs=128k conv=sync
- $(call Image/Build/Profile/DIR615C1,$(1))
- $(call Image/Build/Profile/MZKW04NU,$(1))
- $(call Image/Build/Profile/TEW632BRP,$(1))
- $(call Image/Build/Profile/TEW652BRP,$(1))
- $(call Image/Build/Profile/UBNTRS,$(1))
- $(call Image/Build/Profile/WP543,$(1))
- $(call Image/Build/Profile/TLWR941NDV2,$(1))
+ $(call Image/Build/Profile/$(PROFILE),$(1))
endef
$(eval $(call BuildImage))