summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorZhao Gang <gang.zhao.42@gmail.com>2016-07-15 10:00:04 +0000
committerJo-Philipp Wich <jo@mein.io>2016-07-20 00:21:48 +0200
commitd963ddf0424a551e5fadd561c934bfdb5d198764 (patch)
treef1169f5e1ca6165d9a7953bea25625a939a524af /target/linux/ar71xx/image
parent6c2651566cce8f5b3a3d3b976439dee2bac5e07e (diff)
downloadmaster-31e0f0ae-d963ddf0424a551e5fadd561c934bfdb5d198764.tar.gz
master-31e0f0ae-d963ddf0424a551e5fadd561c934bfdb5d198764.tar.bz2
master-31e0f0ae-d963ddf0424a551e5fadd561c934bfdb5d198764.zip
ar71xx: add support for gl-ar300m
This add initial support for gl-ar300m router. Product page: http://www.gl-inet.com/ar300m/ Signed-off-by: Zhao Gang <gang.zhao.42@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index cbb47f5fe2..b417a3fb15 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -57,6 +57,16 @@ define Device/gl-ar300
endef
TARGET_DEVICES += gl-ar300
+define Device/gl-ar300m
+ DEVICE_TITLE := GL AR300M
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 uboot-envtools
+ BOARDNAME = GL-AR300M
+ IMAGE_SIZE = 16000k
+ CONSOLE = ttyS0,115200
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += gl-ar300m
+
define Device/gl-domino
DEVICE_TITLE := GL Domino Pi
DEVICE_PACKAGES := kmod-usb-core kmod-usb2