summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorAllan Nick Pedrana <nik9993@gmail.com>2016-05-29 17:26:03 -0500
committerJo-Philipp Wich <jo@mein.io>2016-06-07 11:21:55 +0200
commite61fe4e4d762eb3e00c43b6714a229835efc7ea5 (patch)
tree737e21a9790d68f2cc6a51d0bae1f90b96082b5f /target/linux/ar71xx/image
parent69b45d2223e3069407be97fd7b76a14b8d195cee (diff)
downloadmaster-31e0f0ae-e61fe4e4d762eb3e00c43b6714a229835efc7ea5.tar.gz
master-31e0f0ae-e61fe4e4d762eb3e00c43b6714a229835efc7ea5.tar.bz2
master-31e0f0ae-e61fe4e4d762eb3e00c43b6714a229835efc7ea5.zip
ar71xx: add support for OpenEmbed SOM9331
This patch adds the target profile SOM9331 and configures hardware functionality for the 3x Eth Ports & corresponding LED's, the USB Host, the USART to USB bridge and the System LED. Signed-off-by: Allan Nick Pedrana <nik9993@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 012136267a..ca79f98c97 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -271,6 +271,15 @@ define Device/smart-300
endef
TARGET_DEVICES += smart-300
+define Device/som9331
+ $(Device/tplink-8mlzma)
+ BOARDNAME := SOM9331
+ DEVICE_PROFILE := SOM9331
+ TPLINK_HWID := 0x04800054
+ CONSOLE := ttyATH0,115200
+endef
+TARGET_DEVICES += som9331
+
define Device/tellstick-znet-lite
$(Device/tplink-16mlzma)
BOARDNAME := TELLSTICK-ZNET-LITE