summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.14
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-04 06:10:20 +0000
committerJohn Crispin <john@openwrt.org>2015-02-04 06:10:20 +0000
commitcde2225c7c0674fa1b334645cce8ada797cc6a24 (patch)
tree0e8d29130d2cc04dbbd173f3766868099fd06e3b /target/linux/ar71xx/patches-3.14
parenta63e94426de3c2768a9fcb6947702781394de7e1 (diff)
downloadmaster-31e0f0ae-cde2225c7c0674fa1b334645cce8ada797cc6a24.tar.gz
master-31e0f0ae-cde2225c7c0674fa1b334645cce8ada797cc6a24.tar.bz2
master-31e0f0ae-cde2225c7c0674fa1b334645cce8ada797cc6a24.zip
ar71xx: add support for the TP-LINK TL-WR941ND v5
This device is very similar to the TL-WR841N v8, only two LED GPIOs are different. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> SVN-Revision: 44255
Diffstat (limited to 'target/linux/ar71xx/patches-3.14')
-rw-r--r--target/linux/ar71xx/patches-3.14/610-MIPS-ath79-openwrt-machines.patch3
-rw-r--r--target/linux/ar71xx/patches-3.14/720-MIPS-ath79-add-Tube2H-support.patch6
2 files changed, 5 insertions, 4 deletions
diff --git a/target/linux/ar71xx/patches-3.14/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.14/610-MIPS-ath79-openwrt-machines.patch
index b01c5de1ff..0fd64ff6a7 100644
--- a/target/linux/ar71xx/patches-3.14/610-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-3.14/610-MIPS-ath79-openwrt-machines.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -16,22 +16,146 @@
+@@ -16,22 +16,147 @@
enum ath79_mach_type {
ATH79_MACH_GENERIC = 0,
@@ -108,6 +108,7 @@
+ ATH79_MACH_TL_WR841N_V8, /* TP-LINK TL-WR841N/ND v8 */
+ ATH79_MACH_TL_WR842N_V2, /* TP-LINK TL-WR842N/ND v2 */
+ ATH79_MACH_TL_WR941ND, /* TP-LINK TL-WR941ND */
++ ATH79_MACH_TL_WR941ND_V5, /* TP-LINK TL-WR941ND v5 */
ATH79_MACH_UBNT_AIRROUTER, /* Ubiquiti AirRouter */
ATH79_MACH_UBNT_BULLET_M, /* Ubiquiti Bullet M */
+ ATH79_MACH_UBNT_LSSR71, /* Ubiquiti LS-SR71 */
diff --git a/target/linux/ar71xx/patches-3.14/720-MIPS-ath79-add-Tube2H-support.patch b/target/linux/ar71xx/patches-3.14/720-MIPS-ath79-add-Tube2H-support.patch
index 2c948426b7..7a3754ba80 100644
--- a/target/linux/ar71xx/patches-3.14/720-MIPS-ath79-add-Tube2H-support.patch
+++ b/target/linux/ar71xx/patches-3.14/720-MIPS-ath79-add-Tube2H-support.patch
@@ -1,9 +1,9 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -142,6 +142,7 @@ enum ath79_mach_type {
- ATH79_MACH_TL_WR841N_V9, /* TP-LINK TL-WR841N/ND v9 */
+@@ -143,6 +143,7 @@ enum ath79_mach_type {
ATH79_MACH_TL_WR842N_V2, /* TP-LINK TL-WR842N/ND v2 */
ATH79_MACH_TL_WR941ND, /* TP-LINK TL-WR941ND */
+ ATH79_MACH_TL_WR941ND_V5, /* TP-LINK TL-WR941ND v5 */
+ ATH79_MACH_TUBE2H, /* Alfa Network Tube2H */
ATH79_MACH_UBNT_AIRROUTER, /* Ubiquiti AirRouter */
ATH79_MACH_UBNT_BULLET_M, /* Ubiquiti Bullet M */
@@ -28,7 +28,7 @@
select SOC_AR724X
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -117,6 +117,7 @@ obj-$(CONFIG_ATH79_MACH_TL_WR1043ND_V2)
+@@ -117,6 +117,7 @@ obj-$(CONFIG_ATH79_MACH_TL_WR1043ND_V2)
obj-$(CONFIG_ATH79_MACH_TL_WR2543N) += mach-tl-wr2543n.o
obj-$(CONFIG_ATH79_MACH_TL_WR703N) += mach-tl-wr703n.o
obj-$(CONFIG_ATH79_MACH_TL_WR720N_V3) += mach-tl-wr720n-v3.o