summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.1/432-spi-rb4xx-spi-driver.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-19 17:58:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-19 17:58:40 +0000
commit78b1a6b773aaebdeff6f6b43df98598749e44930 (patch)
tree1cacb1c7de856ee70af780d86e6c70b9559bb247 /target/linux/ar71xx/patches-4.1/432-spi-rb4xx-spi-driver.patch
parentd26e8d9439052ed8f433b6ffb15a5f0c54712121 (diff)
downloadmaster-31e0f0ae-78b1a6b773aaebdeff6f6b43df98598749e44930.tar.gz
master-31e0f0ae-78b1a6b773aaebdeff6f6b43df98598749e44930.tar.bz2
master-31e0f0ae-78b1a6b773aaebdeff6f6b43df98598749e44930.zip
ar71xx: add 4.1 support
Signed-off-by: Roman Yeryomin <roman@advem.lv> SVN-Revision: 46426
Diffstat (limited to 'target/linux/ar71xx/patches-4.1/432-spi-rb4xx-spi-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-4.1/432-spi-rb4xx-spi-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.1/432-spi-rb4xx-spi-driver.patch b/target/linux/ar71xx/patches-4.1/432-spi-rb4xx-spi-driver.patch
new file mode 100644
index 0000000000..27159b3bb2
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.1/432-spi-rb4xx-spi-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -433,6 +433,12 @@ config SPI_QUP
+ This driver can also be built as a module. If so, the module
+ will be called spi_qup.
+
++config SPI_RB4XX
++ tristate "Mikrotik RB4XX SPI master"
++ depends on SPI_MASTER && ATH79_MACH_RB4XX
++ help
++ SPI controller driver for the Mikrotik RB4xx series boards.
++
+ config SPI_S3C24XX
+ tristate "Samsung S3C24XX series SPI"
+ depends on ARCH_S3C24XX
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -62,6 +62,7 @@ spi-pxa2xx-platform-$(CONFIG_SPI_PXA2XX_
+ spi-pxa2xx-platform-$(CONFIG_SPI_PXA2XX_DMA) += spi-pxa2xx-dma.o
+ obj-$(CONFIG_SPI_PXA2XX) += spi-pxa2xx-platform.o
+ obj-$(CONFIG_SPI_PXA2XX_PCI) += spi-pxa2xx-pci.o
++obj-$(CONFIG_SPI_RB4XX) += spi-rb4xx.o
+ obj-$(CONFIG_SPI_QUP) += spi-qup.o
+ obj-$(CONFIG_SPI_ROCKCHIP) += spi-rockchip.o
+ obj-$(CONFIG_SPI_RSPI) += spi-rspi.o