summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.4/420-net-ar71xx_mac_driver.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-30 13:19:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-30 13:19:53 +0000
commit2530640f07cd2b3b14fe9ec03fa63a586452cc5f (patch)
treeda4d0e63a6771cbd044d3ba8d8dc97bd0615920f /target/linux/ar71xx/patches-4.4/420-net-ar71xx_mac_driver.patch
parente5b5cce442f6fdaccf86064657518a5d0404f78e (diff)
downloadmaster-31e0f0ae-2530640f07cd2b3b14fe9ec03fa63a586452cc5f.tar.gz
master-31e0f0ae-2530640f07cd2b3b14fe9ec03fa63a586452cc5f.tar.bz2
master-31e0f0ae-2530640f07cd2b3b14fe9ec03fa63a586452cc5f.zip
ar71xx: add support for linux 4.4
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48563
Diffstat (limited to 'target/linux/ar71xx/patches-4.4/420-net-ar71xx_mac_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-4.4/420-net-ar71xx_mac_driver.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.4/420-net-ar71xx_mac_driver.patch b/target/linux/ar71xx/patches-4.4/420-net-ar71xx_mac_driver.patch
new file mode 100644
index 0000000000..feb2e6a393
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.4/420-net-ar71xx_mac_driver.patch
@@ -0,0 +1,28 @@
+--- a/drivers/net/ethernet/atheros/Kconfig
++++ b/drivers/net/ethernet/atheros/Kconfig
+@@ -5,7 +5,7 @@
+ config NET_VENDOR_ATHEROS
+ bool "Atheros devices"
+ default y
+- depends on PCI
++ depends on (PCI || ATH79)
+ ---help---
+ If you have a network (Ethernet) card belonging to this class, say Y.
+
+@@ -78,4 +78,6 @@ config ALX
+ To compile this driver as a module, choose M here. The module
+ will be called alx.
+
++source drivers/net/ethernet/atheros/ag71xx/Kconfig
++
+ endif # NET_VENDOR_ATHEROS
+--- a/drivers/net/ethernet/atheros/Makefile
++++ b/drivers/net/ethernet/atheros/Makefile
+@@ -2,6 +2,7 @@
+ # Makefile for the Atheros network device drivers.
+ #
+
++obj-$(CONFIG_AG71XX) += ag71xx/
+ obj-$(CONFIG_ATL1) += atlx/
+ obj-$(CONFIG_ATL2) += atlx/
+ obj-$(CONFIG_ATL1E) += atl1e/