summaryrefslogtreecommitdiffstats
path: root/target/linux/arm64/image/boot-wrapper/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-18 13:39:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-18 13:39:55 +0000
commitc429250ee49c31cc5e369332f042ada025c84ac2 (patch)
treecf879c700e8cfa85d11af0f645e80ca26bf990b9 /target/linux/arm64/image/boot-wrapper/Makefile
parent69391f49b517c1cc1328fcf9406c605816dd3b17 (diff)
downloadmaster-31e0f0ae-c429250ee49c31cc5e369332f042ada025c84ac2.tar.gz
master-31e0f0ae-c429250ee49c31cc5e369332f042ada025c84ac2.tar.bz2
master-31e0f0ae-c429250ee49c31cc5e369332f042ada025c84ac2.zip
arm64: switch to Kernel 4.1
- fix Kernel dts subdir location - enable virtio networking we are using -M virt which supports virtio devices changes in symbols due to make kernel_oldconfig: - CONFIG_ARCH_BINFMT_ELF_RANDOMIZE_PIE=y : removed fix security: upstream id: d1fd836dcf00d2028c700c7e44d2c23404062c90 - CONFIG_ARM64_CPU_SUSPEND: removed commit id: af3cfdbf56b91785650f54e7c9a899d814b4b9fb - CONFIG_ARM64_PGTABLE_LEVELS=3 : renamed PGTABLE_LEVELS commit id: 9f25e6ad58e1fb3b4d441e4c55635c4598a6fa94 - CONFIG_GENERIC_CLOCKEVENTS_BUILD=y : removed upstream commit id: 9f083b74df3a7eaa100b456f2dc195512daf728e -# CONFIG_PREEMPT_RCU: unnecessary unknown remove reasons: -CONFIG_GENERIC_IOMAP=y -# CONFIG_POWER_RESET_GPIO is not set -# CONFIG_POWER_RESET_GPIO_RESTART is not set -# CONFIG_POWER_RESET_LTC2952 is not set -# CONFIG_POWER_RESET_SYSCON is not set -# CONFIG_XEN is not set tested and boot, networking work with qemu Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> SVN-Revision: 47005
Diffstat (limited to 'target/linux/arm64/image/boot-wrapper/Makefile')
-rw-r--r--target/linux/arm64/image/boot-wrapper/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/arm64/image/boot-wrapper/Makefile b/target/linux/arm64/image/boot-wrapper/Makefile
index cf58590545..fa397087a3 100644
--- a/target/linux/arm64/image/boot-wrapper/Makefile
+++ b/target/linux/arm64/image/boot-wrapper/Makefile
@@ -26,7 +26,7 @@ define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
KERNEL="../Image" \
DTC="$(LINUX_DIR)/scripts/dtc/dtc" \
- FDT_SRC="$(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/dts/foundation-v8.dts" \
+ FDT_SRC="$(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/dts/arm/foundation-v8.dts" \
CROSS_COMPILE="$(TARGET_CROSS)" \
BOOTARGS="console=ttyAMA0 earlyprintk"
endef