summaryrefslogtreecommitdiffstats
path: root/target/linux/at91/patches/700-tqma9263-support.patch
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-01-27 20:54:54 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-01-27 20:54:54 +0000
commit1effec1690958b7d6b907a6a33e15dbf3897a0f5 (patch)
treea875a8256b00ccd156cf8af7c7b81d0396a34525 /target/linux/at91/patches/700-tqma9263-support.patch
parent7c732843072a23d69face2eeb6e00be55d21e401 (diff)
downloadmaster-31e0f0ae-1effec1690958b7d6b907a6a33e15dbf3897a0f5.tar.gz
master-31e0f0ae-1effec1690958b7d6b907a6a33e15dbf3897a0f5.tar.bz2
master-31e0f0ae-1effec1690958b7d6b907a6a33e15dbf3897a0f5.zip
prepare TQ-Components TQMa9263 kernel support
SVN-Revision: 25162
Diffstat (limited to 'target/linux/at91/patches/700-tqma9263-support.patch')
-rw-r--r--target/linux/at91/patches/700-tqma9263-support.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/at91/patches/700-tqma9263-support.patch b/target/linux/at91/patches/700-tqma9263-support.patch
new file mode 100644
index 0000000000..941b4a6654
--- /dev/null
+++ b/target/linux/at91/patches/700-tqma9263-support.patch
@@ -0,0 +1,25 @@
+--- a/arch/arm/mach-at91/Kconfig
++++ b/arch/arm/mach-at91/Kconfig
+@@ -317,6 +317,12 @@
+ help
+ Select this if you are using the Adeneo Neocore 926 board.
+
++config MACH_TQMA9263
++ bool "TQ Components TQMa9263 board"
++ help
++ Select this if you are using the an TQ Components TQMa9263 board.
++ <http://www.tq-components.com/>
++
+ endif
+
+ # ----------------------------------------------------------
+--- a/arch/arm/mach-at91/Makefile
++++ b/arch/arm/mach-at91/Makefile
+@@ -55,6 +55,7 @@
+ obj-$(CONFIG_MACH_AT91SAM9263EK) += board-sam9263ek.o
+ obj-$(CONFIG_MACH_USB_A9263) += board-usb-a9263.o
+ obj-$(CONFIG_MACH_NEOCORE926) += board-neocore926.o
++obj-$(CONFIG_MACH_TQMA9263) += board-tqma9263.o
+
+ # AT91SAM9RL board-specific support
+ obj-$(CONFIG_MACH_AT91SAM9RLEK) += board-sam9rlek.o