summaryrefslogtreecommitdiffstats
path: root/target/linux/au1000/au1500/profiles
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-02-11 15:47:01 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-02-11 15:47:01 +0000
commitc8dcdc9c014118240a05ba9a8fbdb42a2a003fd1 (patch)
tree51ac2eb43c269d05f75150b0dadb1354eaea76e9 /target/linux/au1000/au1500/profiles
parentd5fe04fc76a6580fc72ba96c3993232f816015f3 (diff)
downloadmaster-31e0f0ae-c8dcdc9c014118240a05ba9a8fbdb42a2a003fd1.tar.gz
master-31e0f0ae-c8dcdc9c014118240a05ba9a8fbdb42a2a003fd1.tar.bz2
master-31e0f0ae-c8dcdc9c014118240a05ba9a8fbdb42a2a003fd1.zip
prepare to support more au1x00 targets
SVN-Revision: 14473
Diffstat (limited to 'target/linux/au1000/au1500/profiles')
-rw-r--r--target/linux/au1000/au1500/profiles/Atheros.mk13
-rw-r--r--target/linux/au1000/au1500/profiles/InternetBox.mk19
-rw-r--r--target/linux/au1000/au1500/profiles/MeshCube.mk19
3 files changed, 51 insertions, 0 deletions
diff --git a/target/linux/au1000/au1500/profiles/Atheros.mk b/target/linux/au1000/au1500/profiles/Atheros.mk
new file mode 100644
index 0000000000..ec6e175e80
--- /dev/null
+++ b/target/linux/au1000/au1500/profiles/Atheros.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/au1000/au1500/profiles/InternetBox.mk b/target/linux/au1000/au1500/profiles/InternetBox.mk
new file mode 100644
index 0000000000..ee32ddb13f
--- /dev/null
+++ b/target/linux/au1000/au1500/profiles/InternetBox.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2007-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/InternetBox
+ NAME:=T-Mobile "InternetBox"
+ PACKAGES:=kmod-madwifi \
+ ldconfig ldd \
+ ip tc wpa-supplicant wpa-cli
+endef
+
+define Profile/InternetBox/Description
+ Package set for the T-Mobile "InternetBox" (TMD SB1-S)
+endef
+
+$(eval $(call Profile,InternetBox))
diff --git a/target/linux/au1000/au1500/profiles/MeshCube.mk b/target/linux/au1000/au1500/profiles/MeshCube.mk
new file mode 100644
index 0000000000..ddfae679df
--- /dev/null
+++ b/target/linux/au1000/au1500/profiles/MeshCube.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2007-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MeshCube
+ NAME:=MeshCube MTX-1
+ PACKAGES:=kmod-madwifi kmod-hostap kmod-hostap-pci kmod-net-prism54 \
+ kmod-usb-core kmod-usb-ohci kmod-usb-storage kmod-fs-ext3 kmod-fs-vfat \
+ ldconfig ldd hostap-utils ip tc wpa-supplicant wpa-cli
+endef
+
+define Profile/MeshCube/Description
+ Package set for the 4G MeshCube (MTX-1)
+endef
+
+$(eval $(call Profile,MeshCube))