summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/profiles/211-Broadcom-tg3-wl.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2013-01-24 14:38:10 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2013-01-24 14:38:10 +0000
commit76c12ff797c49940741b107d7b09dc1bdd350670 (patch)
tree5927fec65ee6daf8adcf5680211e9dfdc2c3f62c /target/linux/brcm47xx/profiles/211-Broadcom-tg3-wl.mk
parentb60fc82ce5a7ea7a462d44412c9f96e138bfbd4f (diff)
downloadmaster-31e0f0ae-76c12ff797c49940741b107d7b09dc1bdd350670.tar.gz
master-31e0f0ae-76c12ff797c49940741b107d7b09dc1bdd350670.tar.bz2
master-31e0f0ae-76c12ff797c49940741b107d7b09dc1bdd350670.zip
brcm47xx: change generic profiles
The default profile now contains Ethernet drivers for all the types found on supported boards. There are other profiles for each Ethernet driver. SVN-Revision: 35314
Diffstat (limited to 'target/linux/brcm47xx/profiles/211-Broadcom-tg3-wl.mk')
-rw-r--r--target/linux/brcm47xx/profiles/211-Broadcom-tg3-wl.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/profiles/211-Broadcom-tg3-wl.mk b/target/linux/brcm47xx/profiles/211-Broadcom-tg3-wl.mk
new file mode 100644
index 0000000000..d2788e6377
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/211-Broadcom-tg3-wl.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-tg3-wl
+ NAME:=Broadcom SoC, tg3 Ethernet, BCM43xx WiFi (wl, proprietary)
+ PACKAGES:=-wpad-mini kmod-brcm-wl wlc nas kmod-tg3
+endef
+
+define Profile/Broadcom-tg3-wl/Description
+ Package set compatible with hardware Broadcom BCM4705/BCM4785
+ SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
+ wireless "wl" driver and tg3 Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-tg3-wl))
+