summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image/Makefile
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-03-25 15:34:59 +0000
committerJonas Gorski <jogo@openwrt.org>2015-03-25 15:34:59 +0000
commit065d6e9047d235ffa916dcf0ce330bfc124e2fd0 (patch)
tree8e217d356df413aeee7b56bd89ac3fd5ee6d6046 /target/linux/brcm63xx/image/Makefile
parentee0140a678a0955d0883bebcc87e7e2a42eca800 (diff)
downloadmaster-31e0f0ae-065d6e9047d235ffa916dcf0ce330bfc124e2fd0.tar.gz
master-31e0f0ae-065d6e9047d235ffa916dcf0ce330bfc124e2fd0.tar.bz2
master-31e0f0ae-065d6e9047d235ffa916dcf0ce330bfc124e2fd0.zip
brcm63xx: move kernel load address to 8MiB
Fixes boot when uncompressed kernel is > 4 MiB (#19251). Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 44984
Diffstat (limited to 'target/linux/brcm63xx/image/Makefile')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 47756bf39b..a55fc46d6c 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-LOADADDR = 0x80010000 # RAM start + 64K
+LOADADDR = 0x80800000 # RAM start + 8MB
KERNEL_ENTRY = $(LOADADDR) # Newer kernels add a jmp to the kernel_entry at the start of the binary
RAMSIZE = 0x02000000 # 32MB
LZMA_TEXT_START = 0x81800000 # 32MB - 8MB