summaryrefslogtreecommitdiffstats
path: root/target/linux/gemini/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-05-11 18:27:33 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-05-11 18:27:33 +0000
commitf24a7c7a68902ef157d8caa7b950a20874b95081 (patch)
tree58beb40f86c6fdbbb4ea6df2e9c1cd832b280786 /target/linux/gemini/Makefile
parent35d191875884e17a1148476d1a4c22783188a5a4 (diff)
downloadmaster-31e0f0ae-f24a7c7a68902ef157d8caa7b950a20874b95081.tar.gz
master-31e0f0ae-f24a7c7a68902ef157d8caa7b950a20874b95081.tar.bz2
master-31e0f0ae-f24a7c7a68902ef157d8caa7b950a20874b95081.zip
add preliminary support for the successor of the storm port
SVN-Revision: 15772
Diffstat (limited to 'target/linux/gemini/Makefile')
-rw-r--r--target/linux/gemini/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/gemini/Makefile b/target/linux/gemini/Makefile
new file mode 100644
index 0000000000..9b3a0de83c
--- /dev/null
+++ b/target/linux/gemini/Makefile
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=gemini
+BOARDNAME:=Cortina Systems CS351x
+FEATURES:=jffs2 broken
+CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -mno-thumb-interwork -funit-at-a-time
+
+LINUX_VERSION:=2.6.30-rc5
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))