summaryrefslogtreecommitdiffstats
path: root/target/linux/gemini/patches-4.4/110-watchdog-add-gemini_wdt-driver.patch
diff options
context:
space:
mode:
authorRoman Yeryomin <roman@advem.lv>2016-08-22 02:36:50 +0300
committerJo-Philipp Wich <jo@mein.io>2016-08-23 15:41:27 +0200
commitf046737e92f9a13acbe9139e1ded83287d31eeb5 (patch)
treea99693b42935d5d4ea1addf3514003df4e7898bd /target/linux/gemini/patches-4.4/110-watchdog-add-gemini_wdt-driver.patch
parente58c20aac319e5d9722caed2d64b6338c6b04b85 (diff)
downloadmaster-31e0f0ae-f046737e92f9a13acbe9139e1ded83287d31eeb5.tar.gz
master-31e0f0ae-f046737e92f9a13acbe9139e1ded83287d31eeb5.tar.bz2
master-31e0f0ae-f046737e92f9a13acbe9139e1ded83287d31eeb5.zip
gemini: add Linux 4.4 support
Signed-off-by: Roman Yeryomin <roman@advem.lv> [Jo-Philipp Wich: change commit title] Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/gemini/patches-4.4/110-watchdog-add-gemini_wdt-driver.patch')
-rw-r--r--target/linux/gemini/patches-4.4/110-watchdog-add-gemini_wdt-driver.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/gemini/patches-4.4/110-watchdog-add-gemini_wdt-driver.patch b/target/linux/gemini/patches-4.4/110-watchdog-add-gemini_wdt-driver.patch
new file mode 100644
index 0000000000..bb66ae4dd0
--- /dev/null
+++ b/target/linux/gemini/patches-4.4/110-watchdog-add-gemini_wdt-driver.patch
@@ -0,0 +1,29 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -229,6 +229,16 @@ config 977_WATCHDOG
+
+ Not sure? It's safe to say N.
+
++config GEMINI_WATCHDOG
++ tristate "Gemini watchdog"
++ depends on ARCH_GEMINI
++ help
++ Say Y here if to include support for the watchdog timer
++ embedded in the Cortina Systems Gemini family of devices.
++
++ To compile this driver as a module, choose M here: the
++ module will be called gemini_wdt.
++
+ config IXP4XX_WATCHDOG
+ tristate "IXP4xx Watchdog"
+ depends on ARCH_IXP4XX
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -37,6 +37,7 @@ obj-$(CONFIG_OMAP_WATCHDOG) += omap_wdt.
+ obj-$(CONFIG_TWL4030_WATCHDOG) += twl4030_wdt.o
+ obj-$(CONFIG_21285_WATCHDOG) += wdt285.o
+ obj-$(CONFIG_977_WATCHDOG) += wdt977.o
++obj-$(CONFIG_GEMINI_WATCHDOG) += gemini_wdt.o
+ obj-$(CONFIG_IXP4XX_WATCHDOG) += ixp4xx_wdt.o
+ obj-$(CONFIG_KS8695_WATCHDOG) += ks8695_wdt.o
+ obj-$(CONFIG_S3C2410_WATCHDOG) += s3c2410_wdt.o