summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/050-build_flags.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-01-06 19:28:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-01-06 19:28:07 +0000
commit178721f76bf6e298b36f6cbfc725ea3ce689a57c (patch)
tree72016cc3537dd7524b206cab8c8d44b197efec1d /target/linux/generic-2.4/patches/050-build_flags.patch
parent563d234596124a2e8a3f8489b8a82bd018ed87a7 (diff)
downloadmaster-31e0f0ae-178721f76bf6e298b36f6cbfc725ea3ce689a57c.tar.gz
master-31e0f0ae-178721f76bf6e298b36f6cbfc725ea3ce689a57c.tar.bz2
master-31e0f0ae-178721f76bf6e298b36f6cbfc725ea3ce689a57c.zip
update brcm-2.4 to 2.4.35.4, integrate new broadcom system code, update broadcom-wl to a contributed version (v4.150.10.5) - no bcm57xx support yet, will follow shortly
SVN-Revision: 10137
Diffstat (limited to 'target/linux/generic-2.4/patches/050-build_flags.patch')
-rw-r--r--target/linux/generic-2.4/patches/050-build_flags.patch18
1 files changed, 10 insertions, 8 deletions
diff --git a/target/linux/generic-2.4/patches/050-build_flags.patch b/target/linux/generic-2.4/patches/050-build_flags.patch
index 14a207df23..5eab6334e0 100644
--- a/target/linux/generic-2.4/patches/050-build_flags.patch
+++ b/target/linux/generic-2.4/patches/050-build_flags.patch
@@ -1,6 +1,7 @@
-diff -ur linux-2.4.32/arch/mips/Makefile linux-2.4.32-openwrt/arch/mips/Makefile
---- linux-2.4.32/arch/mips/Makefile 2005-12-15 13:53:59.000000000 +0100
-+++ linux-2.4.32-openwrt/arch/mips/Makefile 2005-12-15 14:02:33.000000000 +0100
+Index: linux-2.4.35.4/arch/mips/Makefile
+===================================================================
+--- linux-2.4.35.4.orig/arch/mips/Makefile 2007-12-15 05:19:44.870978088 +0100
++++ linux-2.4.35.4/arch/mips/Makefile 2007-12-15 05:19:50.987326639 +0100
@@ -44,10 +44,10 @@
GCCFLAGS := -I $(TOPDIR)/include/asm/gcc
GCCFLAGS += -G 0 -mno-abicalls -fno-pic -pipe
@@ -48,9 +49,10 @@ diff -ur linux-2.4.32/arch/mips/Makefile linux-2.4.32-openwrt/arch/mips/Makefile
CFLAGS += $(GCCFLAGS)
LD += -m $(ld-emul)
-diff -ur linux-2.4.32/Makefile linux-2.4.32-openwrt/Makefile
---- linux-2.4.32/Makefile 2005-12-15 13:53:59.000000000 +0100
-+++ linux-2.4.32-openwrt/Makefile 2005-12-15 13:59:30.000000000 +0100
+Index: linux-2.4.35.4/Makefile
+===================================================================
+--- linux-2.4.35.4.orig/Makefile 2007-12-15 05:19:45.074989715 +0100
++++ linux-2.4.35.4/Makefile 2007-12-15 05:19:50.995327098 +0100
@@ -17,7 +17,7 @@
FINDHPATH = $(HPATH)/asm $(HPATH)/linux $(HPATH)/scsi $(HPATH)/net $(HPATH)/math-emu
@@ -70,9 +72,9 @@ diff -ur linux-2.4.32/Makefile linux-2.4.32-openwrt/Makefile
-CFLAGS := $(CPPFLAGS) -Wall -Wstrict-prototypes -Wno-trigraphs -O2 \
+CFLAGS := $(CPPFLAGS) -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
-fno-strict-aliasing -fno-common
- CFLAGS += -fno-builtin-sprintf
+ CFLAGS += -fno-builtin-strpbrk -fno-builtin-sprintf
ifndef CONFIG_FRAME_POINTER
-@@ -104,6 +103,8 @@
+@@ -105,6 +104,8 @@
# disable pointer signedness warnings in gcc 4.0
CFLAGS += $(call check_gcc,-Wno-pointer-sign,)