summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/615-netfilter_nat_mms.patch
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2009-05-15 10:36:04 +0000
committerAndy Boyett <agb@openwrt.org>2009-05-15 10:36:04 +0000
commit88e632d853ac18fc82ef245486ed952ef124739c (patch)
tree21c2c051c41c9aa3cc6edb39362386b75b78643b /target/linux/generic-2.4/patches/615-netfilter_nat_mms.patch
parent94921686de5f1ded59d5b3bc79812b31bf4fca48 (diff)
downloadmaster-31e0f0ae-88e632d853ac18fc82ef245486ed952ef124739c.tar.gz
master-31e0f0ae-88e632d853ac18fc82ef245486ed952ef124739c.tar.bz2
master-31e0f0ae-88e632d853ac18fc82ef245486ed952ef124739c.zip
generic-2.4: refresh patches
SVN-Revision: 15860
Diffstat (limited to 'target/linux/generic-2.4/patches/615-netfilter_nat_mms.patch')
-rw-r--r--target/linux/generic-2.4/patches/615-netfilter_nat_mms.patch30
1 files changed, 9 insertions, 21 deletions
diff --git a/target/linux/generic-2.4/patches/615-netfilter_nat_mms.patch b/target/linux/generic-2.4/patches/615-netfilter_nat_mms.patch
index 8fe407582e..a95b652ef3 100644
--- a/target/linux/generic-2.4/patches/615-netfilter_nat_mms.patch
+++ b/target/linux/generic-2.4/patches/615-netfilter_nat_mms.patch
@@ -1,7 +1,5 @@
-Index: linux-2.4.35.4/net/ipv4/netfilter/Config.in
-===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/Config.in
-+++ linux-2.4.35.4/net/ipv4/netfilter/Config.in
+--- a/net/ipv4/netfilter/Config.in
++++ b/net/ipv4/netfilter/Config.in
@@ -17,6 +17,7 @@ if [ "$CONFIG_IP_NF_CONNTRACK" != "n" ];
dep_tristate ' PPTP protocol support' CONFIG_IP_NF_PPTP $CONFIG_IP_NF_CT_PROTO_GRE
dep_tristate ' H.323 (netmeeting) support' CONFIG_IP_NF_H323 $CONFIG_IP_NF_CONNTRACK
@@ -24,10 +22,8 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/Config.in
if [ "$CONFIG_EXPERIMENTAL" = "y" ]; then
dep_tristate ' Basic SNMP-ALG support (EXPERIMENTAL)' CONFIG_IP_NF_NAT_SNMP_BASIC $CONFIG_IP_NF_NAT
fi
-Index: linux-2.4.35.4/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.4.35.4/net/ipv4/netfilter/Makefile
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
@@ -61,6 +61,10 @@ obj-$(CONFIG_IP_NF_RTSP) += ip_conntrack
ifdef CONFIG_IP_NF_NAT_RTSP
export-objs += ip_conntrack_rtsp.o
@@ -47,10 +43,8 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/Makefile
# generic IP tables
obj-$(CONFIG_IP_NF_IPTABLES) += ip_tables.o
-Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_mms.c
-===================================================================
--- /dev/null
-+++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_mms.c
++++ b/net/ipv4/netfilter/ip_conntrack_mms.c
@@ -0,0 +1,292 @@
+/* MMS extension for IP connection tracking
+ * (C) 2002 by Filip Sneppe <filip.sneppe@cronos.be>
@@ -344,10 +338,8 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_mms.c
+
+module_init(init);
+module_exit(fini);
-Index: linux-2.4.35.4/net/ipv4/netfilter/ip_nat_mms.c
-===================================================================
--- /dev/null
-+++ linux-2.4.35.4/net/ipv4/netfilter/ip_nat_mms.c
++++ b/net/ipv4/netfilter/ip_nat_mms.c
@@ -0,0 +1,330 @@
+/* MMS extension for TCP NAT alteration.
+ * (C) 2002 by Filip Sneppe <filip.sneppe@cronos.be>
@@ -679,10 +671,8 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ip_nat_mms.c
+
+module_init(init);
+module_exit(fini);
-Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack.h
-===================================================================
---- linux-2.4.35.4.orig/include/linux/netfilter_ipv4/ip_conntrack.h
-+++ linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack.h
+--- a/include/linux/netfilter_ipv4/ip_conntrack.h
++++ b/include/linux/netfilter_ipv4/ip_conntrack.h
@@ -73,6 +73,7 @@ union ip_conntrack_expect_proto {
#include <linux/netfilter_ipv4/ip_conntrack_pptp.h>
#include <linux/netfilter_ipv4/ip_conntrack_h323.h>
@@ -707,10 +697,8 @@ Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack.h
};
#ifdef CONFIG_IP_NF_NAT_NEEDED
-Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack_mms.h
-===================================================================
--- /dev/null
-+++ linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack_mms.h
++++ b/include/linux/netfilter_ipv4/ip_conntrack_mms.h
@@ -0,0 +1,31 @@
+#ifndef _IP_CONNTRACK_MMS_H
+#define _IP_CONNTRACK_MMS_H