summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.28/410-gpio_buttons.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-12-08 13:23:09 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-12-08 13:23:09 +0000
commitf21f51d858ab97a4784f76481c336613abc127f6 (patch)
treee1d1a3380f15b3a411c3eeffb9adea9f6f82628b /target/linux/generic-2.6/patches-2.6.28/410-gpio_buttons.patch
parent206ccdf4ae2f236a752950a701bb3eacbdaf2cc8 (diff)
downloadmaster-31e0f0ae-f21f51d858ab97a4784f76481c336613abc127f6.tar.gz
master-31e0f0ae-f21f51d858ab97a4784f76481c336613abc127f6.tar.bz2
master-31e0f0ae-f21f51d858ab97a4784f76481c336613abc127f6.zip
add generic 2.6.28 patches
SVN-Revision: 13546
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.28/410-gpio_buttons.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/410-gpio_buttons.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.28/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.28/410-gpio_buttons.patch
new file mode 100644
index 0000000000..198557aac1
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.28/410-gpio_buttons.patch
@@ -0,0 +1,30 @@
+--- a/drivers/input/misc/Kconfig
++++ b/drivers/input/misc/Kconfig
+@@ -220,4 +220,20 @@ config HP_SDC_RTC
+ Say Y here if you want to support the built-in real time clock
+ of the HP SDC controller.
+
++config INPUT_GPIO_BUTTONS
++ tristate "Polled GPIO buttons interface"
++ depends on GENERIC_GPIO
++ select INPUT_POLLDEV
++ help
++ This driver implements support for buttons connected
++ to GPIO pins of various CPUs (and some other chips).
++
++ Say Y here if your device has buttons connected
++ directly to such GPIO pins. Your board-specific
++ setup logic must also provide a platform device,
++ with configuration data saying which GPIOs are used.
++
++ To compile this driver as a module, choose M here: the
++ module will be called gpio-buttons.
++
+ endif
+--- a/drivers/input/misc/Makefile
++++ b/drivers/input/misc/Makefile
+@@ -21,3 +21,4 @@ obj-$(CONFIG_HP_SDC_RTC) += hp_sdc_rtc.
+ obj-$(CONFIG_INPUT_UINPUT) += uinput.o
+ obj-$(CONFIG_INPUT_APANEL) += apanel.o
+ obj-$(CONFIG_INPUT_SGI_BTNS) += sgi_btns.o
++obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o