summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.32/081-mtd_myloader_partition_parser.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-05 11:43:34 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-05 11:43:34 +0000
commit2e3f8c480e4e27cb843553820aff019cf7cb2649 (patch)
tree84982919b31a0221ba9a0d5a4f0f732f399262d9 /target/linux/generic/patches-2.6.32/081-mtd_myloader_partition_parser.patch
parente005aed2231ce7bce0214061ea0d7f546c7fec24 (diff)
downloadmaster-31e0f0ae-2e3f8c480e4e27cb843553820aff019cf7cb2649.tar.gz
master-31e0f0ae-2e3f8c480e4e27cb843553820aff019cf7cb2649.tar.bz2
master-31e0f0ae-2e3f8c480e4e27cb843553820aff019cf7cb2649.zip
linux/2.6.32: R.I.P.
SVN-Revision: 31597
Diffstat (limited to 'target/linux/generic/patches-2.6.32/081-mtd_myloader_partition_parser.patch')
-rw-r--r--target/linux/generic/patches-2.6.32/081-mtd_myloader_partition_parser.patch35
1 files changed, 0 insertions, 35 deletions
diff --git a/target/linux/generic/patches-2.6.32/081-mtd_myloader_partition_parser.patch b/target/linux/generic/patches-2.6.32/081-mtd_myloader_partition_parser.patch
deleted file mode 100644
index 61b822ee88..0000000000
--- a/target/linux/generic/patches-2.6.32/081-mtd_myloader_partition_parser.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/drivers/mtd/Kconfig
-+++ b/drivers/mtd/Kconfig
-@@ -181,6 +181,22 @@ config MTD_AR7_PARTS
- ---help---
- TI AR7 partitioning support
-
-+config MTD_MYLOADER_PARTS
-+ tristate "MyLoader partition parsing"
-+ depends on MTD_PARTITIONS && (ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX)
-+ ---help---
-+ MyLoader is a bootloader which allows the user to define partitions
-+ in flash devices, by putting a table in the second erase block
-+ on the device, similar to a partition table. This table gives the
-+ offsets and lengths of the user defined partitions.
-+
-+ If you need code which can detect and parse these tables, and
-+ register MTD 'partitions' corresponding to each image detected,
-+ enable this option.
-+
-+ You will still need the parsing functions to be called by the driver
-+ for your particular device. It won't happen automatically.
-+
- comment "User Modules And Translation Layers"
-
- config MTD_CHAR
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdli
- obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
- obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
- obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
-+obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
-
- # 'Users' - code which presents functionality to userspace.
- obj-$(CONFIG_MTD_CHAR) += mtdchar.o