summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.12/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-10-24 13:50:11 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-10-24 13:50:11 +0000
commite72c7e17a475c00134c56f4392578ddc16a47a2e (patch)
tree842835f958f9c9ed315cb853173d51e43f76bbf5 /target/linux/generic/patches-3.12/940-ocf_kbuild_integration.patch
parent4341ea40379ed24c103e37b75661c62bfc3270f6 (diff)
downloadmaster-31e0f0ae-e72c7e17a475c00134c56f4392578ddc16a47a2e.tar.gz
master-31e0f0ae-e72c7e17a475c00134c56f4392578ddc16a47a2e.tar.bz2
master-31e0f0ae-e72c7e17a475c00134c56f4392578ddc16a47a2e.zip
preliminary 3.12 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 38528
Diffstat (limited to 'target/linux/generic/patches-3.12/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-3.12/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.12/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-3.12/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..e04ac948c0
--- /dev/null
+++ b/target/linux/generic/patches-3.12/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -1397,3 +1397,6 @@ source "drivers/crypto/Kconfig"
+ source crypto/asymmetric_keys/Kconfig
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -99,6 +99,8 @@ obj-$(CONFIG_CRYPTO_USER_API) += af_alg.
+ obj-$(CONFIG_CRYPTO_USER_API_HASH) += algif_hash.o
+ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #