summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.19/302-mips_no_branch_likely.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-01-25 15:20:39 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-01-25 15:20:39 +0000
commitd26694243af236fed09a4b38f3cc68e40ad063b5 (patch)
treedf356ae59718ae0996986ccb61155243098dbc3f /target/linux/generic/patches-3.19/302-mips_no_branch_likely.patch
parenta46bb6ec6a0ed6eb56dc2f4551a57e63a7292753 (diff)
downloadmaster-31e0f0ae-d26694243af236fed09a4b38f3cc68e40ad063b5.tar.gz
master-31e0f0ae-d26694243af236fed09a4b38f3cc68e40ad063b5.tar.bz2
master-31e0f0ae-d26694243af236fed09a4b38f3cc68e40ad063b5.zip
generic: add preliminary 3.19 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 44126
Diffstat (limited to 'target/linux/generic/patches-3.19/302-mips_no_branch_likely.patch')
-rw-r--r--target/linux/generic/patches-3.19/302-mips_no_branch_likely.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.19/302-mips_no_branch_likely.patch b/target/linux/generic/patches-3.19/302-mips_no_branch_likely.patch
new file mode 100644
index 0000000000..19adcb800b
--- /dev/null
+++ b/target/linux/generic/patches-3.19/302-mips_no_branch_likely.patch
@@ -0,0 +1,11 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -87,7 +87,7 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
+ # machines may also. Since BFD is incredibly buggy with respect to
+ # crossformat linking we rely on the elf2ecoff tool for format conversion.
+ #
+-cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
++cflags-y += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
+ cflags-y += -msoft-float
+ LDFLAGS_vmlinux += -G 0 -static -n -nostdlib --gc-sections --sort-section=name
+ KBUILD_AFLAGS_MODULE += -mlong-calls