summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.0/259-regmap_dynamic.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-07 16:22:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-07 16:22:08 +0000
commitad133b57a94165e1289ac63b38139047a1450dbb (patch)
treeb59d5e2f60aface2db357eef2bd87d5d448c26a3 /target/linux/generic/patches-4.0/259-regmap_dynamic.patch
parent86a46a817ba7cfab4963818f9c97508f1f835762 (diff)
downloadmaster-31e0f0ae-ad133b57a94165e1289ac63b38139047a1450dbb.tar.gz
master-31e0f0ae-ad133b57a94165e1289ac63b38139047a1450dbb.tar.bz2
master-31e0f0ae-ad133b57a94165e1289ac63b38139047a1450dbb.zip
kernel: remove linux 4.0 support
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47412
Diffstat (limited to 'target/linux/generic/patches-4.0/259-regmap_dynamic.patch')
-rw-r--r--target/linux/generic/patches-4.0/259-regmap_dynamic.patch84
1 files changed, 0 insertions, 84 deletions
diff --git a/target/linux/generic/patches-4.0/259-regmap_dynamic.patch b/target/linux/generic/patches-4.0/259-regmap_dynamic.patch
deleted file mode 100644
index 084b3b4450..0000000000
--- a/target/linux/generic/patches-4.0/259-regmap_dynamic.patch
+++ /dev/null
@@ -1,84 +0,0 @@
---- a/drivers/base/regmap/Kconfig
-+++ b/drivers/base/regmap/Kconfig
-@@ -3,29 +3,35 @@
- # subsystems should select the appropriate symbols.
-
- config REGMAP
-- default y if (REGMAP_I2C || REGMAP_SPI || REGMAP_SPMI || REGMAP_AC97 || REGMAP_MMIO || REGMAP_IRQ)
- select LZO_COMPRESS
- select LZO_DECOMPRESS
- select IRQ_DOMAIN if REGMAP_IRQ
-- bool
-+ tristate "Regmap"
-
- config REGMAP_AC97
-+ select REGMAP
- tristate
-
- config REGMAP_I2C
-- tristate
-+ tristate "Regmap I2C"
-+ select REGMAP
- depends on I2C
-
- config REGMAP_SPI
-- tristate
-+ tristate "Regmap SPI"
-+ select REGMAP
-+ depends on SPI_MASTER
- depends on SPI
-
- config REGMAP_SPMI
-+ select REGMAP
- tristate
- depends on SPMI
-
- config REGMAP_MMIO
-- tristate
-+ tristate "Regmap MMIO"
-+ select REGMAP
-
- config REGMAP_IRQ
-+ select REGMAP
- bool
---- a/include/linux/regmap.h
-+++ b/include/linux/regmap.h
-@@ -50,7 +50,7 @@ struct reg_default {
- unsigned int def;
- };
-
--#ifdef CONFIG_REGMAP
-+#if IS_ENABLED(CONFIG_REGMAP)
-
- enum regmap_endian {
- /* Unspecified -> 0 -> Backwards compatible default */
---- a/drivers/base/regmap/Makefile
-+++ b/drivers/base/regmap/Makefile
-@@ -1,6 +1,8 @@
--obj-$(CONFIG_REGMAP) += regmap.o regcache.o
--obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o regcache-flat.o
--obj-$(CONFIG_DEBUG_FS) += regmap-debugfs.o
-+regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-lzo.o regcache-flat.o
-+ifdef CONFIG_DEBUG_FS
-+regmap-core-objs += regmap-debugfs.o
-+endif
-+obj-$(CONFIG_REGMAP) += regmap-core.o
- obj-$(CONFIG_REGMAP_AC97) += regmap-ac97.o
- obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o
- obj-$(CONFIG_REGMAP_SPI) += regmap-spi.o
---- a/drivers/base/regmap/regmap.c
-+++ b/drivers/base/regmap/regmap.c
-@@ -13,6 +13,7 @@
- #include <linux/device.h>
- #include <linux/slab.h>
- #include <linux/export.h>
-+#include <linux/module.h>
- #include <linux/mutex.h>
- #include <linux/err.h>
- #include <linux/of.h>
-@@ -2631,3 +2632,5 @@ static int __init regmap_initcall(void)
- return 0;
- }
- postcore_initcall(regmap_initcall);
-+
-+MODULE_LICENSE("GPL");