summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.1/011-perf-tools-Fix-makefile-generation-under-dash.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-14 01:00:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-14 01:00:38 +0000
commit09ad818ffcadd504b932b9403503af5a960423f8 (patch)
treef660a84e721f21611cfb00579282edd90dd50b8b /target/linux/generic/patches-4.1/011-perf-tools-Fix-makefile-generation-under-dash.patch
parent021f3834a7039ac04740c7cf2ed4ca7ee7305601 (diff)
downloadmaster-31e0f0ae-09ad818ffcadd504b932b9403503af5a960423f8.tar.gz
master-31e0f0ae-09ad818ffcadd504b932b9403503af5a960423f8.tar.bz2
master-31e0f0ae-09ad818ffcadd504b932b9403503af5a960423f8.zip
kernel: backport perf build fixes to 4.1
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48231
Diffstat (limited to 'target/linux/generic/patches-4.1/011-perf-tools-Fix-makefile-generation-under-dash.patch')
-rw-r--r--target/linux/generic/patches-4.1/011-perf-tools-Fix-makefile-generation-under-dash.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.1/011-perf-tools-Fix-makefile-generation-under-dash.patch b/target/linux/generic/patches-4.1/011-perf-tools-Fix-makefile-generation-under-dash.patch
new file mode 100644
index 0000000000..45ea1a04f2
--- /dev/null
+++ b/target/linux/generic/patches-4.1/011-perf-tools-Fix-makefile-generation-under-dash.patch
@@ -0,0 +1,27 @@
+From: Sergei Trofimovich <siarheit@google.com>
+Date: Sun, 19 Jul 2015 10:30:05 +0100
+Subject: [PATCH] perf tools: Fix makefile generation under dash
+
+Under dash 'echo -n' yields '-n' to stdout. Use printf "" instead.
+
+Signed-off-by: Sergei Trofimovich <siarheit@google.com>
+Acked-by: Ingo Molnar <mingo@kernel.org>
+Acked-by: Jiri Olsa <jolsa@kernel.org>
+Cc: Adrian Hunter <adrian.hunter@intel.com>
+Cc: Namhyung Kim <namhyung@kernel.org>
+Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
+Link: http://lkml.kernel.org/r/1437298205-29305-1-git-send-email-siarheit@google.com
+Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
+---
+
+--- a/tools/perf/config/Makefile
++++ b/tools/perf/config/Makefile
+@@ -11,7 +11,7 @@ ifneq ($(obj-perf),)
+ obj-perf := $(abspath $(obj-perf))/
+ endif
+
+-$(shell echo -n > $(OUTPUT).config-detected)
++$(shell printf "" > $(OUTPUT).config-detected)
+ detected = $(shell echo "$(1)=y" >> $(OUTPUT).config-detected)
+ detected_var = $(shell echo "$(1)=$($(1))" >> $(OUTPUT).config-detected)
+