summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.3/729-phy-tantos.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-10-11 19:08:08 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-10-11 19:08:08 +0000
commitb5842aed82e0c9101e99ec4bcf5959b931e98989 (patch)
treef9749eb8ce7d61f284cc4d91bac5aafd07de8344 /target/linux/generic/patches-4.3/729-phy-tantos.patch
parent3d1a65adb41db2758827fe81f36d92ab61618ea3 (diff)
downloadmaster-31e0f0ae-b5842aed82e0c9101e99ec4bcf5959b931e98989.tar.gz
master-31e0f0ae-b5842aed82e0c9101e99ec4bcf5959b931e98989.tar.bz2
master-31e0f0ae-b5842aed82e0c9101e99ec4bcf5959b931e98989.zip
kernel: generic: add kernel 4.3
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 47182
Diffstat (limited to 'target/linux/generic/patches-4.3/729-phy-tantos.patch')
-rw-r--r--target/linux/generic/patches-4.3/729-phy-tantos.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.3/729-phy-tantos.patch b/target/linux/generic/patches-4.3/729-phy-tantos.patch
new file mode 100644
index 0000000000..49d1d89f67
--- /dev/null
+++ b/target/linux/generic/patches-4.3/729-phy-tantos.patch
@@ -0,0 +1,21 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -301,3 +301,8 @@ endif # PHYLIB
+ config MICREL_KS8995MA
+ tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
+ depends on SPI
++
++config PSB6970_PHY
++ tristate "Lantiq XWAY Tantos (PSB6970) Ethernet switch"
++ select SWCONFIG
++ select ETHERNET_PACKET_MANGLE
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -32,6 +32,7 @@ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
++obj-$(CONFIG_PSB6970_PHY) += psb6970.o
+ obj-$(CONFIG_FIXED_PHY) += fixed_phy.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o