summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/patches/000-boards.patch
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2012-06-05 00:43:56 +0000
committerLuka Perkov <luka@openwrt.org>2012-06-05 00:43:56 +0000
commit605012ad5d540dabd2d3f843e1e2a8d61241c724 (patch)
tree9ab0bfddc9761a24bb62249be9c98af6c3636c2b /target/linux/kirkwood/patches/000-boards.patch
parentdc9e7207396bdb7cab49a6f58c1f7c8a28139a53 (diff)
downloadmaster-31e0f0ae-605012ad5d540dabd2d3f843e1e2a8d61241c724.tar.gz
master-31e0f0ae-605012ad5d540dabd2d3f843e1e2a8d61241c724.tar.bz2
master-31e0f0ae-605012ad5d540dabd2d3f843e1e2a8d61241c724.zip
kirkwood: reorganize target
SVN-Revision: 32053
Diffstat (limited to 'target/linux/kirkwood/patches/000-boards.patch')
-rw-r--r--target/linux/kirkwood/patches/000-boards.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/target/linux/kirkwood/patches/000-boards.patch b/target/linux/kirkwood/patches/000-boards.patch
new file mode 100644
index 0000000000..4fe376e9bc
--- /dev/null
+++ b/target/linux/kirkwood/patches/000-boards.patch
@@ -0,0 +1,38 @@
+--- a/arch/arm/mach-kirkwood/Makefile
++++ b/arch/arm/mach-kirkwood/Makefile
+@@ -18,5 +18,8 @@ obj-$(CONFIG_MACH_D2NET_V2) += d2net_v2
+ obj-$(CONFIG_MACH_NET2BIG_V2) += netxbig_v2-setup.o lacie_v2-common.o
+ obj-$(CONFIG_MACH_NET5BIG_V2) += netxbig_v2-setup.o lacie_v2-common.o
+ obj-$(CONFIG_MACH_T5325) += t5325-setup.o
++obj-$(CONFIG_MACH_ICONNECT) += iconnect-setup.o
++obj-$(CONFIG_MACH_NAS6210) += nas6210-setup.o
++obj-$(CONFIG_MACH_NSA310) += nsa-310-setup.o
+
+ obj-$(CONFIG_CPU_IDLE) += cpuidle.o
+--- a/arch/arm/mach-kirkwood/Kconfig
++++ b/arch/arm/mach-kirkwood/Kconfig
+@@ -130,6 +130,24 @@ config MACH_T5325
+ Say 'Y' here if you want your kernel to support the
+ HP t5325 Thin Client.
+
++config MACH_ICONNECT
++ bool "Iomega iConnect Wireless"
++ help
++ Say 'Y' here if you want your kernel to support the
++ Iomega iConnect Wireless.
++
++config MACH_NAS6210
++ bool "RaidSonic ICY BOX IB-NAS6210"
++ help
++ Say 'Y' here if you want your kernel to support the
++ RaidSonic ICY BOX IB-NAS6210 device.
++
++config MACH_NSA310
++ bool "ZyXEL NSA-310"
++ help
++ Say 'Y' here if you want your kernel to support the
++ ZyXEL NSA-310 board.
++
+ endmenu
+
+ endif