summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-4.1/0002-MIPS-lantiq-dtb-image-hack.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-07 13:43:47 +0000
committerJohn Crispin <john@openwrt.org>2015-07-07 13:43:47 +0000
commitff08b0957026645e436c3388aa3f3f0032765106 (patch)
treebd023d085ea8774e977bc7200bf396eb7b1dca78 /target/linux/lantiq/patches-4.1/0002-MIPS-lantiq-dtb-image-hack.patch
parent2658b33f68403dfc39b7cab6d27b9140284b6b92 (diff)
downloadmaster-31e0f0ae-ff08b0957026645e436c3388aa3f3f0032765106.tar.gz
master-31e0f0ae-ff08b0957026645e436c3388aa3f3f0032765106.tar.bz2
master-31e0f0ae-ff08b0957026645e436c3388aa3f3f0032765106.zip
lantiq: Add support for linux 4.1
All (still relevant) patches were refresh. The following patches were dropped because they are applied upstream: - 0003-MIPS-lantiq-handle-vmmc-memory-reservation.patch - 0005-MIPS-lantiq-add-reset-controller-api-support.patch - 0006-MIPS-lantiq-reboot-gphy-on-restart.patch - 0009-MIPS-lantiq-command-line-work-around.patch - 0010-MIPS-lantiq-export-soc-type.patch - 0011-lantiq-add-support-for-xrx200-firmware-depending-on-.patch - 0037-MIPS-lantiq-move-eiu-init-after-irq_domain-register.patch Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> SVN-Revision: 46216
Diffstat (limited to 'target/linux/lantiq/patches-4.1/0002-MIPS-lantiq-dtb-image-hack.patch')
-rw-r--r--target/linux/lantiq/patches-4.1/0002-MIPS-lantiq-dtb-image-hack.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/lantiq/patches-4.1/0002-MIPS-lantiq-dtb-image-hack.patch b/target/linux/lantiq/patches-4.1/0002-MIPS-lantiq-dtb-image-hack.patch
new file mode 100644
index 0000000000..a68607c75b
--- /dev/null
+++ b/target/linux/lantiq/patches-4.1/0002-MIPS-lantiq-dtb-image-hack.patch
@@ -0,0 +1,31 @@
+From 17348293f7f8103c97c8d2a6b0ef36eae06ec371 Mon Sep 17 00:00:00 2001
+From: John Crispin <blogic@openwrt.org>
+Date: Wed, 13 Mar 2013 09:36:16 +0100
+Subject: [PATCH 02/36] MIPS: lantiq: dtb image hack
+
+Signed-off-by: John Crispin <blogic@openwrt.org>
+---
+ arch/mips/lantiq/Makefile | 2 --
+ arch/mips/lantiq/prom.c | 4 +++-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+--- a/arch/mips/lantiq/prom.c
++++ b/arch/mips/lantiq/prom.c
+@@ -63,6 +63,8 @@ static void __init prom_init_cmdline(voi
+ }
+ }
+
++extern struct boot_param_header __image_dtb;
++
+ void __init plat_mem_setup(void)
+ {
+ ioport_resource.start = IOPORT_RESOURCE_START;
+@@ -76,7 +78,7 @@ void __init plat_mem_setup(void)
+ * Load the builtin devicetree. This causes the chosen node to be
+ * parsed resulting in our memory appearing
+ */
+- __dt_setup_arch(__dtb_start);
++ __dt_setup_arch(&__image_dtb);
+
+ strlcpy(arcs_cmdline, boot_command_line, COMMAND_LINE_SIZE);
+ }