summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches/250-watchdog.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-03-11 08:19:53 +0000
committerJohn Crispin <john@openwrt.org>2011-03-11 08:19:53 +0000
commitc75b0ca1a8e6e9c1ffd43719792ab1903085aa93 (patch)
tree4a1a3044e0f7acb02f16849a8758e292ff66ae7d /target/linux/lantiq/patches/250-watchdog.patch
parent58a5102338f7fde82c0a025d99f044868c979d02 (diff)
downloadmaster-31e0f0ae-c75b0ca1a8e6e9c1ffd43719792ab1903085aa93.tar.gz
master-31e0f0ae-c75b0ca1a8e6e9c1ffd43719792ab1903085aa93.tar.bz2
master-31e0f0ae-c75b0ca1a8e6e9c1ffd43719792ab1903085aa93.zip
* update kernel to .37 * add support for falcon (big thank you goes to lantiq !!)
SVN-Revision: 26021
Diffstat (limited to 'target/linux/lantiq/patches/250-watchdog.patch')
-rw-r--r--target/linux/lantiq/patches/250-watchdog.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/lantiq/patches/250-watchdog.patch b/target/linux/lantiq/patches/250-watchdog.patch
index f86ff71868..6f727c4273 100644
--- a/target/linux/lantiq/patches/250-watchdog.patch
+++ b/target/linux/lantiq/patches/250-watchdog.patch
@@ -1,8 +1,8 @@
--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
-@@ -840,6 +840,12 @@ config TXX9_WDT
- help
- Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+@@ -930,6 +930,12 @@
+ To compile this driver as a loadable module, choose M here.
+ The module will be called bcm63xx_wdt.
+config LANTIQ_WDT
+ bool "Lantiq SoC watchdog"
@@ -15,10 +15,10 @@
# POWERPC Architecture
--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
-@@ -112,6 +112,7 @@ obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt
- obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
- obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+@@ -119,6 +119,7 @@
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
+ obj-$(CONFIG_OCTEON_WDT) += octeon-wdt.o
+ octeon-wdt-y := octeon-wdt-main.o octeon-wdt-nmi.o
+obj-$(CONFIG_LANTIQ_WDT) += lantiq_wdt.o
# PARISC Architecture
@@ -167,7 +167,7 @@
+static const struct file_operations lq_wdt_fops = {
+ .owner = THIS_MODULE,
+ .write = lq_wdt_write,
-+ .ioctl = lq_wdt_ioctl,
++ .unlocked_ioctl = lq_wdt_ioctl,
+ .open = lq_wdt_open,
+ .release = lq_wdt_release,
+};