summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-07-07 18:20:31 +0000
committerJohn Crispin <john@openwrt.org>2011-07-07 18:20:31 +0000
commitdc2af3308380e430f9f6fef0380c4b85bae2d3a1 (patch)
tree0c20a35a7b69efb0698b60dc489600f855812ab9 /target/linux/lantiq
parent3c1079a7a7d7773cd2d29a9183209f9438746047 (diff)
downloadmaster-31e0f0ae-dc2af3308380e430f9f6fef0380c4b85bae2d3a1.tar.gz
master-31e0f0ae-dc2af3308380e430f9f6fef0380c4b85bae2d3a1.tar.bz2
master-31e0f0ae-dc2af3308380e430f9f6fef0380c4b85bae2d3a1.zip
fix lantiq image makefile to represent new split between ar9 and danube
SVN-Revision: 27537
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/Makefile29
1 files changed, 20 insertions, 9 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index b1ef0a5cde..43ad0e88f3 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -136,14 +136,6 @@ define Image/Build/Profile/ARV752DPW22
$(call Image/Build/$(1),$(1),ARV752DPW22)
endef
-define Image/BuildKernel/Profile/DGN3500B
- $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
-endef
-
-define Image/Build/Profile/DGN3500B
- $(call Image/Build/$(1),$(1),DGN3500B)
-endef
-
define Image/BuildKernel/Profile/GIGASX76X
$(call Image/BuildKernel/Template,GIGASX76X,$(xway_cmdline))
endef
@@ -166,7 +158,6 @@ define Image/BuildKernel/Profile/Generic
$(call Image/BuildKernel/Template,ARV752DPW,$(xway_cmdline))
$(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
$(call Image/BuildKernel/Template,GIGASX76X,$(xway_cmdline))
- $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
$(call Image/BuildKernel/Template,NONE)
endef
@@ -184,6 +175,26 @@ define Image/Build/Profile/Generic
$(call Image/Build/$(1),$(1),ARV752DPW)
$(call Image/Build/$(1),$(1),ARV752DPW22)
$(call Image/Build/$(1),$(1),GIGASX76X)
+ $(call Image/Build/$(1),$(1),NONE)
+ $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs
+endef
+endif
+
+ifeq ($(CONFIG_TARGET_lantiq_ar9),y)
+define Image/BuildKernel/Profile/DGN3500B
+ $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/DGN3500B
+ $(call Image/Build/$(1),$(1),DGN3500B)
+endef
+
+define Image/BuildKernel/Profile/Generic
+ $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
+ $(call Image/BuildKernel/Template,NONE)
+endef
+
+define Image/Build/Profile/Generic
$(call Image/Build/$(1),$(1),DGN3500B)
$(call Image/Build/$(1),$(1),NONE)
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs