summaryrefslogtreecommitdiffstats
path: root/target/linux/magicbox-2.6/image/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-11-28 20:14:41 +0000
committerMike Baker <mbm@openwrt.org>2006-11-28 20:14:41 +0000
commitc3c4dfb57beebd26c0534698b8687c2c7c94e1f5 (patch)
tree6ffc51e355fb56df1c38449e6c16711d0b27a29c /target/linux/magicbox-2.6/image/Makefile
parent16edf83d62c8a8bc446b5d9a74de27c2dd4f3d8b (diff)
downloadmaster-31e0f0ae-c3c4dfb57beebd26c0534698b8687c2c7c94e1f5.tar.gz
master-31e0f0ae-c3c4dfb57beebd26c0534698b8687c2c7c94e1f5.tar.bz2
master-31e0f0ae-c3c4dfb57beebd26c0534698b8687c2c7c94e1f5.zip
move target/image/platform to target/linux/platform/image platform directories are now self contained
SVN-Revision: 5669
Diffstat (limited to 'target/linux/magicbox-2.6/image/Makefile')
-rw-r--r--target/linux/magicbox-2.6/image/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/target/linux/magicbox-2.6/image/Makefile b/target/linux/magicbox-2.6/image/Makefile
new file mode 100644
index 0000000000..10f71df2a9
--- /dev/null
+++ b/target/linux/magicbox-2.6/image/Makefile
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Build/Clean
+endef
+
+define Image/Prepare
+endef
+
+define Image/BuildKernel
+ cp $(LINUX_DIR)/arch/ppc/boot/images/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+ ( \
+ dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=65536 conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=65536 conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+endef
+
+#define Image/Build/jffs2-128k
+# ( \
+# dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=131072 conv=sync; \
+# dd if=$(KDIR)/root.$(1) bs=131072 conv=sync; \
+# ) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+#endef
+
+$(eval $(call BuildImage))