summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-09-08 14:19:34 +0200
committerFelix Fietkau <nbd@nbd.name>2016-09-10 12:17:39 +0200
commit3cbb7820a41057ef3be7b80f35d812fd8b03c9be (patch)
treed17445b8dde2a264512d4404c842f36e64c231e6 /target/linux/mvebu/image/Makefile
parentbee30de984e4e2b98936d13fd611ae5909063087 (diff)
downloadmaster-31e0f0ae-3cbb7820a41057ef3be7b80f35d812fd8b03c9be.tar.gz
master-31e0f0ae-3cbb7820a41057ef3be7b80f35d812fd8b03c9be.tar.bz2
master-31e0f0ae-3cbb7820a41057ef3be7b80f35d812fd8b03c9be.zip
mvebu: use ext4/f2fs overlay filesystem for solidrun clearfog
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/mvebu/image/Makefile')
-rw-r--r--target/linux/mvebu/image/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 09f075bbdb..f3eda17a0b 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -34,7 +34,6 @@ endef
# MBR: 2048 sectors
# Partition 1: 32768 sectors
# Partition 2: 98304 sectors (configurable)
-# Partition 3: 7611392 sectors (configurable, depends on p2 size)
define Build/boot-scr
rm -f $@.bootscript
@@ -50,16 +49,11 @@ define Build/boot-img
endef
define Build/sdcard-img
- rm -rf $@ $@.rootfsdata $@.tmp
- mkdir -p $@.tmp
ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
- DATA_SIZE=$$(( 7709696 - ($(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2) )); \
- make_ext4fs -J -l $$DATA_SIZE $@.rootfsdata $@.tmp && \
- ./gen_mvebu_sdcard_img.sh 7744512 $@ \
+ ./gen_mvebu_sdcard_img.sh $@ \
"$(BIN_DIR)/uboot-mvebu-clearfog/openwrt-mvebu-clearfog-u-boot-spl.kwb" \
c 32768 $@.boot \
- 83 $$ROOTFS_SIZE $(IMAGE_ROOTFS) \
- 83 $$DATA_SIZE $@.rootfsdata
+ 83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
endef
define Device/Default
@@ -182,7 +176,7 @@ define Device/armada-388-clearfog
KERNEL_INSTALL := 1
KERNEL := dtb | kernel-bin
DEVICE_TITLE := SolidRun ClearFog
- DEVICE_PACKAGES := uboot-mvebu-clearfog
+ DEVICE_PACKAGES := uboot-mvebu-clearfog mkf2fs e2fsprogs
IMAGES := bundle.tar.gz sdcard.img.gz
IMAGE/bundle.tar.gz := clearfog-bundle
IMAGE/sdcard.img.gz := boot-scr | boot-img | sdcard-img | gzip